大智慧公式-龙抓手主图指标公式

05/13/2019

RSV2:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*1000;
W1:=SMA(RSV2,3,1);
W2:=SMA(w1,3,1);
W3:=3*W1-2*w2;
W4:=LLV(w3,2)=LLV(w3,8);
W5:=IF(CROSS(w3,REF(w3+0.01,1)) AND w4 AND w3<20,30,0);
DRAWTEXT(CROSS(w3,REF(w3+0.01,1)) AND w4 AND w3<20,LOW-0.05,'龙'),ALIGN1,VALIGN0,COLORred;
{以下内容设置五线谱}
{B:(ma(close,5)+ma(close,3))/2;}
A:=(ma(close,13)+ma(close,8))/2;
牛熊线:=EMA(C,64);
上轨:=牛熊线*1.2;
上轨2:=牛熊线*1.41;
下轨:=牛熊线*0.8;
下轨1:=牛熊线*0.618;
{以下设置操作线}
操作线:EMA((SLOPE(CLOSE,21)*20+CLOSE),42),colorwhite;
对照线:=ma(操作线,2);
partline(操作线,对照线<=操作线),colorred,linethick1;
支撑:= SMA(AMOUNT/VOL/100,5,1)*0.85;
压力:= SMA(AMOUNT/VOL/100,5,1)*1.1;
超卖线:= SMA(AMOUNT/VOL/100,5,1)*0.79;
{以下定义开盘跌停}
DT:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
跌停:=COUNT(DT<-9.98,1)=1;
大幅跌:=count(dt<-6.4,1)=1;
{以下定义超跌与抢反弹}
严重超跌:=cross(low,超卖线);
drawtext(严重超跌,low,'严重超跌');
超跌1:=low/超卖线<=1.048 and not(COUNT(DT<-9.98,1)=1)and not (count(dt<-7,1)=1);
drawtext(超跌1,low,'←超跌');
超跌3:=(cross(l,支撑) or low/超卖线<=1.03)and (low/下轨<=1.02 or low/下轨1<=1.02) and not(COUNT(DT<-9.98,1)=1)and not (count(dt<-6,1)=1);
drawtext(超跌3,low*0.98,'←抢反弹'),colorwhite;
超级短线:=(cross(l,支撑) or cross(low,超卖线) or low/支撑<=0.98 or low/超卖线<=0.98 ) and low/open>=0.95 and (count(dt<-8,1)=1) and not(COUNT(DT<-9.98,2)=2);
drawtext(超级短线,low,'←龙抓手'),colorred;
;
{财神:=(操作线/low>=1.40);
drawtext(财神,low,'财'),colorgreen;
drawtext(财神,low*0.95,'神'),colorgreen;
drawtext(财神,low*0.9,'到'),colorgreen;}
{以下定义主升}
drawtext((cross(a,操作线) and A>操作线),low,'【大蓄】'),colorwhite,ALIGN1,VALIGN0;
{以下设置老鼠仓};
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099ff;
DRAWTEXT(老鼠仓,low,'☆'),ALIGN1,VALIGN0,COLOR0099ff;
{以下定义顶底背离}
LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR1880FF;
{以下定义坚决买进}
var77:=ema(amount/vol/100,3);
var88:=ema(var77,88);
var99:=ema(var77,88)*0.85;
varah:=var99*0.87;
varbh:=low<varah and close>ref(close,1)*1.02;
drawtext(filter(varbh,6),l-0.08,'←买'),colorff00ff;
{以下设置强势狙击}
BB05:=atan(((MA(C,5))/ref((MA(C,5)),1)-1)*100)*180/3.1416;
BB10:=atan(((MA(C,10))/ref((MA(C,10)),1)-1)*100)*180/3.1416;
BB30:=atan(((MA(C,30))/ref((MA(C,30)),1)-1)*100)*180/3.1416;
强势狙击:=filter(BB30>30 and BB10>45 and cross(BB05,60),10);
drawtext(强势狙击,LOW*0.98,'←强势'),colorwhite;
{以下定义资金进场}
VAR3e:=100-(100-3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR4e:=100-(100-3*SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,20,1),15,1));
VAR5e:=VAR3e>REF(VAR4e,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXTABS(5,5,' '),linethick1,COLOR00EEff;
DRAWTEXT(VAR5e AND COUNT(VAR5e,30)=1,low,'资金进场'),COLORYELLOW;
{以下设置K线颜色}
stickline((open >= close),close,open,9,7),colorff5b00;
stickline((open >= close),close,open,8,0),colorff6c00;
stickline((open >= close),close,open,7,0),colorff7b00;
stickline((open >= close),close,open,6,0),colorff9c00;
stickline((open >= close),close,open,5,0),colorffbe00;
stickline((open >= close),close,open,3.5,0),colorffcc00;
stickline((open >= close),close,open,1.5,0),colorffff00;
stickline((close >= open),close,open,9,0),color070084;
stickline((close >= open),close,open,8,0),color0000a3;
stickline((close >= open),close,open,7,0),color0000b7;
stickline((close >= open),close,open,6,0),color0000cd;
stickline((close >= open),close,open,5,0),color0000e9;
stickline((close >= open),close,open,3,0),color0754e9;
stickline((close >= open),close,open,1.5,0),color076ef3;
stickline((close >= open),close,open,1,0),color077bf3;
stickline((close > open),open,low,1,0),color0726ca;
stickline((close > open),close,high,1,0),color0726ca;
stickline((open > close),close,low,1,0),colorde9100;
stickline((open > close),open,high,1,0),colorde9100;
stickline(((((close / open) > 1.04) and (close < (sma(high,21,2) * 1.05))) and ((close - ref(close,1)) > 0)),close,open,9,0),color0090ff;
stickline(((((close / open) > 1.04) and (close < (sma(high,21,2) * 1.05))) and ((close - ref(close,1)) > 0)),close,open,8,0),color009fff;
stickline(((((close / open) > 1.04) and (close < (sma(high,21,2) * 1.05))) and ((close - ref(close,1)) > 0)),close,open,4,0),color00b5ff;
stickline(((((close / open) > 1.04) and (close < (sma(high,21,2) * 1.05))) and ((close - ref(close,1)) > 0)),close,open,2,0),color00e4ff;
stickline(((((close / open) > 1.04) and (close < (sma(high,21,2) * 1.05))) and ((close - ref(close,1)) > 0)),open,low,0.7,0),color00ffff;
stickline(((((close / open) > 1.04) and (close < (sma(high,21,2) * 1.05))) and ((close - ref(close,1)) > 0)),close,high,0.7,0),color00ffff;
stickline(((((close < ref(close,1)) and (close < ref(close,1))) and (high > (sma(high,21,2) * 1.05))) and (close < (sma(high,21,2) * 1.05))),open,low,0.7,0),colorff76ff;
stickline(((((close < ref(close,1)) and (close < ref(close,1))) and (high > (sma(high,21,2) * 1.05))) and (close < (sma(high,21,2) * 1.05))),close,high,0.7,0),colorff76ff;
stickline(((((close < ref(close,1)) and (close < ref(close,1))) and (high > (sma(high,21,2) * 1.05))) and (close < (sma(high,21,2) * 1.05))),close,open,9,0),colorff00ff;
stickline(((((close < ref(close,1)) and (close < ref(close,1))) and (high > (sma(high,21,2) * 1.05))) and (close < (sma(high,21,2) * 1.05))),close,open,6,0),colorff62ff;
stickline(((((close < ref(close,1)) and (close < ref(close,1))) and (high > (sma(high,21,2) * 1.05))) and (close < (sma(high,21,2) * 1.05))),close,open,4,0),colorff76ff;
stickline(((((close < ref(close,1)) and (close < ref(close,1))) and (high > (sma(high,21,2) * 1.05))) and (close < (sma(high,21,2) * 1.05))),close,open,2,0),colorffa8ff;

这个大智慧龙抓手主图指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。