大智慧公式-十字光标主图指标公式

04/07/2019

DRAWGBKLAST(C>0,STRIP(RGB(10,10,50),RGB(60,13,10),0));MA5:MA(CLOSE,5),COLORF00FF0,PRECIS2,LAYER0;
MA10:MA(CLOSE,10),COLORYELLOW,PRECIS2,LAYER0;
MA20:MA(C,20),COLORE66878,PRECIS2,LAYER0;MA30:MA(C,30),COLORWHITE;
W:=BARSLAST(DISPSTATUS=1);
P:=BACKSET(DISPSTATUS=2,W/2+1);
K:=BARSLAST(CROSS(P,0.5));
KJ:=HHVALL(HIGH)-LLVALL(LOW);
VERTLINE(CROSS(P,0.5),4),COLOR00FFFF;
平衡:LLVALL(LOW)+KJ/2,Color0099FF,DOTLINE,PRECIS2;
FILLRGN(平衡,HHVALL(HIGH),W>K,RGB(0,0,200)),PRECIS2;{该行设置背景色}
压力:IF(K>=0,HHVALL(HIGH)-KJ*0.191,平衡),COLORFF00FF,DOTLINE,PRECIS2;
支撑:IF(K>=0,LLVALL(LOW)+KJ*0.191,平衡),COLOR00FF00,DOTLINE,PRECIS2;
低吸:K>=0 and CROSS(平衡,LOW),COLORFF8899,LINETHICK0,PRECIS2;
低涨:(C/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
天:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXT(HIGH=HHVALL(HIGH) and K>=0,HIGH*1.01,'←'+NUMTOSTRN(HIGH,2)),COLORFFFFFF;
DRAWICON(低吸,LOW,6);
{以下设置提示文字部分}
DRAWTEXT(DISPSTATUS=2,压力,'0.809'),COLOR0000FF,ALIGN0;
DRAWTEXT(DISPSTATUS=2,平衡,'0.500'),COLORFFFFFF,ALIGN0;
DRAWTEXT(DISPSTATUS=2,支撑,'0.191'),COLOR00FFFF,ALIGN0;
DRAWTEXT(K=0,HHVALL(HIGH)-KJ/12,'★强势区域--急拉减仓!'),COLOR00FFFF,ALIGN1;
DRAWTEXT(K=0,HHVALL(HIGH)-KJ/3,'●震荡整理--寻机低吸!'),COLOR00FF00,ALIGN1;
DRAWTEXT(K=0,LLVALL(LOW)+KJ/3,'◆反弹中轨--逢高休息!'),COLORFFFFFF,ALIGN1;
DRAWTEXT(K=0,LLVALL(LOW)+KJ/10,'■弱势区域--暂不参与!'),COLORFFFF00,ALIGN1;
{以下设置个股信息}
DRAWTEXTREL(10,80,'■低点至今上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天,0)+'天'),COLOR0000FF;
DRAWTEXTREL(10,130,'■目前可见K线:'+NUMTOSTRN(W+1,0)+'天'),colorwhite;
DRAWTEXTREL(10,180,'■建议查阅K线:短线30天,中长线120天!'),COLORFF8899;
{以下设置五彩立体K线}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;
卖:EMA(c+(h-l)*0.618,3),Color0099FF,LINETHICK0;买:EMA((o+h+l)/3,4),COLORCYAN,LINETHICK0;

预测明日买点:=EMA((o+h+l)/3,4)+((h+l)/2-ref((o+h+l)/3,3))/4;
DRAWTEXTREL(800,950,'测今日低点:'+NUMTOSTRN(ref(预测明日买点,1),2 )),ColorGREEN;
预测明日卖点:=EMA(c+(h-l)*0.618,3)+(EMA(c+(h-l)*0.618,3)-买)*0.618;
DRAWTEXTREL(580,950,'测今日高点:'+NUMTOSTRN(ref(预测明日卖点,1),2 )),Colorred;
a:="[email protected]";
s1:="[email protected]_S1";
hs:="[email protected]_HS";
ls:="[email protected]_LS";
p1:="[email protected]_P1";
upp:="[email protected]_UPP";
udd:="[email protected]_UDD";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
买入:p1=1 and ref(p1,1)=0,LineThick0,Precis0,ColorRed;
d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s1=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';
bs:=''+datestr(date)+'买卖点决策系统提示\n'+'1.BS点:'+tr2+','+tr0+'2.短线:'+tr3+tr1+'\n'+tr4;
drawflagtext(1,fb,bs);
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
年线:MA(C,240),COLOR000999,POINTDOT;X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWICON(CROSS(X2,X3),L*0.98,7);
DRAWICON(CROSS(X3,X2),H*1.02,8);
STICKLINE(X2>=X3,LOW,HIGH,0.1,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,2,2),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,2,8),COLORBROWN;
STICKLINE(X2<X3,LOW,HIGH,0.1,1),COLORGREEN;
STICKLINE(X2<X3,CLOSE,OPEN,2,2),COLORGREEN;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,2,1),COLORYELLOW;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,2,1),COLORBLUE;TODAY:="ddx.ddx"=0;{判断是否有正版数据}
DD:=1-(SELFDATA('特大买入')+SELFDATA('大单买入')+SELFDATA('中单买入'));
{TODAY1:=DD>ref(DD,1) or DD<ref(DD,1)=0;{判断是否有理想数据}
TODAY1:=DYNAINFO(7)=CLOSE and DYNAINFO(10)=AMOUNT AND TIME0<55800;
{6}
特大净买:=IF(TODAY,IF(TODAY1,"[email protected]"(1,3),SELFDATA('特大买入')),bigorder(1,3));
大单净买:=IF(TODAY,IF(TODAY1,("[email protected]"(1,2)-"[email protected]"(1,3)),SELFDATA('大单买入')),(bigorder(1,2)-bigorder(1,3)));
大单强度:=大单净买*vol/CAPITAL*100;
特单强度:=特大净买*vol/CAPITAL*100;
a1:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+'【大盘成交】'+NUMTOSTRN(INDEXA/100000000,2)+'亿'+' 【上涨】'+DYNAINFO(69)+'家\n';
a2:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+'【平盘】'+DYNAINFO(71)+'家'+' 【下跌】'+NUMTOSTRN(DYNAINFO(70),0)+'家\n';
a3:='<*t=E7FFFF*><*c=000100*><*p=95*>'+ ' ★★★★'+STKNAME+'('+STKLABEL+')'+ '★★★★\n';
a4:='<*t=E7FFFF*><*c=000000*><*p=95*>'+'今涨:'+NUMTOSTRN(DYNAINFO(14)*100,2)+'% 今换:'+NUMTOSTRN(DYNAINFO(37)*100,2 )+'% 量比:'+NUMTOSTRN(DYNAINFO(17),2 )+' 现价:'+NUMTOSTRN(c,2)+'元\n';
a7:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+'特大主力增仓: '+NUMTOSTRN(特单强度,3)+'% 资金流入: '+NUMTOSTRN(特大净买*AMOUNT/10000,2)+'万元\n';
a8:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+'大单主力增仓: '+NUMTOSTRN(大单强度,3)+'% 资金流入: '+NUMTOSTRN(大单净买*AMOUNT/10000,2)+'万元\n';
a9:='<*t=E7FFFF*><*c=000000*><*p=95*>'+'→→→→→→→→→→→→←←←←←←←←←←←←←\n';
a10:='<*t=E7FFFF*><*c=000000*><*p=95*>'+'一日主力增仓: '+NUMTOSTRN(sum(大单强度+特单强度,1),3)+'% 资金流入: '+NUMTOSTRN(sum(((大单净买+特大净买)*AMOUNT/10000),1),2)+'万元\n';
a11:='<*t=E7FFFF*><*c=000000*><*p=95*>'+'二日主力增仓: '+NUMTOSTRN(sum(大单强度+特单强度,2),3)+'% 资金流入: '+NUMTOSTRN(sum(((大单净买+特大净买)*AMOUNT/10000),2),2)+'万元\n';
a12:='<*t=E7FFFF*><*c=000000*><*p=95*>'+'三日主力增仓: '+NUMTOSTRN(sum(大单强度+特单强度,3),3)+'% 资金流入: '+NUMTOSTRN(sum(((大单净买+特大净买)*AMOUNT/10000),3),2)+'万元\n';
a13:='<*t=E7FFFF*><*c=000000*><*p=95*>'+'四日主力增仓: '+NUMTOSTRN(sum(大单强度+特单强度,4),3)+'% 资金流入: '+NUMTOSTRN(sum(((大单净买+特大净买)*AMOUNT/10000),4),2)+'万元\n';
a14:='<*t=E7FFFF*><*c=000000*><*p=95*>'+'五日主力增仓: '+NUMTOSTRN(sum(大单强度+特单强度,5),3)+'% 资金流入: '+NUMTOSTRN(sum(((大单净买+特大净买)*AMOUNT/10000),5),2)+'万元\n';
DD1:=TROUGH(2,5,1);
目标价一:=DD1*1.1618;
目标价二:=DD1*1.0809;
目标价三:=DD1*1.0809*1.1618;
MB1:='<*t=0092F7*><*c=colorred*><*p=95*>'+'冲高卖出价: '+NUMTOSTRN(目标价一,3)+'元\n';
MB2:='<*t=0092F7*><*c=colorred*><*p=95*>'+' 回调买入价: '+NUMTOSTRN(目标价二,3)+'元\n';
MB3:='<*t=0092F7*><*c=colorred*><*p=95*>'+' 二次冲高卖出价: '+NUMTOSTRN(目标价三,3)+'元';
DRAWFLAGTEXT(c>0,HIGH,a1+a2+a3+a4+a7+a8+a9+a10+a11+a12+a13+a14+MB1+MB2+MB3);

这个大智慧十字光标主图指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。