通达信公式-绝无仅有分时指标公式

02/04/2019

DI11:=DYNAINFO(11);DI17:=DYNAINFO(17);
RCB:=(COUNT(C>0,FROMOPEN)-1-MOD(COUNT(C>0,FROMOPEN)-1,10))/10+1;
RCD:=EMA(LOG(SMA(SUM(DYNAINFO(37),FROMOPEN)*2400000/RCB,3,1)),240);
RCA:=(C/DYNAINFO(11)-(MA(C/DYNAINFO(11),55)+MA(C/DYNAINFO(11),21)+MA(C/DYNAINFO(11),34))/3)/MA(C/DYNAINFO(11),3)*1200;
RCC:=2*((EMA(C,12)-EMA(C,26))*600/DYNAINFO(11)-EMA((EMA(C,12)-EMA(C,26))*600/DYNAINFO(11),9))*10;
RAA:=SUM(AMOUNT,40)/(AMOUNT/VOL/100)/100;
RAB:=SUM(AMOUNT,80)/(AMOUNT/VOL/100)/100;
RAC:=(CLOSE-DMA((3*H+L+O+2*C)/7,VOL/RAA))/DMA((3*H+L+O+2*C)/7,VOL/RAA)*(9000/RCD);
RAD:=(CLOSE-DMA((3*H+L+O+2*C)/7,VOL/RAB))/DMA((3*H+L+O+2*C)/7,VOL/RAB)*(9000/RCD);
RBA:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
JXA:=IF(RAD>0,RAD-100,-100);
JXB:=IF(RADJXC:=IF(RAC>0,RAC-100,-100);
JXD:=IF(RACREA:=EMA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),3);
REB:=EMA(100-3*SMA((LLV(L,75)-C)/(HHV(H,75)-LLV(L,75))*100,18,1)+2*SMA(SMA((LLV(L,75)-C)/(HHV(H,75)-LLV(L,75))*100,18,1),15,1)-100,3);
REC:=100*(HHV(H,55)-C)/(HHV(H,55)-LLV(C,55));
RED:=(EXPMA(C,500)-REF(EXPMA(C,500),1))/REF(EXPMA(C,500),1)*61800;
REE:=(REA+REB-REC+50)/135;
{以上为计算区}
DRAWBAND(RCA,RGB(255,20,107),0,RGB(34,139,34));
DRAWBAND(RCC,RGB(175,255,47),0,RGB(106,90,205));
DRAWBAND(JXA,RGB(255,0,0),-100,RGB(0,0,0));
DRAWBAND(100,RGB(0,255,0),JXB,RGB(0,0,0));
DRAWBAND(JXC,RGB(255,255,0),-100,RGB(0,0,0));
DRAWBAND(100,RGB(0,0,255),JXD,RGB(0,0,0));
STICKLINE(-(EMA(RBA,3)-50)*1.2>39*1.2,39*1.2,-(EMA(RBA,3)-50)*1.2,0,0),COLORLICYAN;
STICKLINE(-(EMA(RBA,3)-50)*1.2{以上为绘图区}
必卖:IF(REE>0.8,REE,DRAWNULL),NODRAW,COLORRED;
必买:IF(REE危险:IF(0机遇:IF(REE>-0.8 AND REE卖:IF(C>COST(86),COST(95),DRAWNULL),NODRAW,COLORLIRED;
买:IF(C点:IF(RED1.2,RED*0.382,DRAWNULL),NODRAW,COLORLIBLUE;
趋势:(REB*2-100)/1.2,COLORWHITE,LINETHICK2;
LRX:=((C/(SUM(V*C,FROMOPEN)/SUM(V,FROMOPEN))-1)*61.8+(C/(SUM(V*C,0)/SUM(V,0))-1)*38.2)*((C/DI11-1)*68.2+(C/EMA(C,480)-1)*38.2);
IF(LRX>0.618 AND C>DI11,SQRT(LRX)*19.1-100,-100),COLORCYAN,LINETHICK5;
IF(LRX>0.618 AND CHQV1:=(COUNT(C>0,FROMOPEN)-1-MOD(COUNT(C>0,FROMOPEN)-1,10))/10+1;
HQV2:=LOG(SMA(SUM(DYNAINFO(37),FROMOPEN)*2400000/HQV1,3,1))-1;
TS9:=IF(HQV2>REF(HQV2,1),' +',IF(HQV2=REF(HQV2,1),' =',' -'));
TSA:=IF(HQV2>3.6,'A级',IF(HQV2>2.7,'B级',IF(HQV2>1.8,'C级',IF(HQV2>0.9,'D级','E级'))));
TSB:=IF(DI17>10,'A级',IF(DI17>5,'B级',IF(DI17>1.5,'C级',IF(DYNAINFO(17)>0.8,'D级','E级'))));
TSC:=IF(DYNAINFO(17)-REF(DYNAINFO(17),1)>REF(DYNAINFO(17)-REF(DYNAINFO(17),1),1),' +',IF(DYNAINFO(17)-REF(DYNAINFO(17),1)=REF(DYNAINFO(17)-REF(DYNAINFO(17),1),1),' =',' -'));
TIM:=IF(COUNT(C>0,FROMOPEN)>119,30,1);
DRAWTEXT(CURRBARSCOUNT=TIM,90,STRCAT('能:',STRCAT(TSB,TSC))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=TIM,-90,STRCAT('量:',STRCAT(TSA,TS9))),COLORGREEN;

这个通达信绝无仅有分时指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。