飞狐公式-趋势为先指标公式

01/27/2020

DRAWGBK(1,COLORRGB(0,0,20),COLORRGB(0,60,50),1);
N:=5;qj0:=(HIGH+LOW+CLOSE)/3;
qj1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
qj2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-qj0);
qj3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
qj4:=IF(HIGH=LOW,1,qj0-MIN(CLOSE,OPEN));
qj5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
qj6:="macd.diff">"macd.dea" and "macd.dea"<0;
qj7:="kdj.k">"kdj.d" and "kdj.d"<30;
qj8:="macd.diff"<"macd.dea";
qj9:="kdj.k"<"kdj.d" and "kdj.k">80;
特大:qj4*qj5,LINETHICK,PRECISION0;大单:qj3*qj5,LINETHICK,PRECISION0;
中单:qj1*qj5,LINETHICK,PRECISION0;小单:qj2*qj5,LINETHICK,PRECISION0;
w1:=SUM(大单,N)+SUM(特大,N);w2:=SUM(小单,n)+SUM(中单,n);
量振1:=特大>大单 and 大单>小单;
量振2:=特大<小单 and 大单<小单;
标振1:=qj6 and qj7;
标振2:=qj8 and qj9;
a:=w1-w2;a0:=IF(a>0,a,0);b0:=IF(a<0,a,0);
STICKLINE(a0,0,a0,8,0),Color000044;
STICKLINE(a0,0,a0,5,0),Color000088;
STICKLINE(a0,0,a0,3,0),Color0000aa;
STICKLINE(a0,0,a0,1,0),Color0000cc;
STICKLINE(b0,0,-b0,8,0),Color004400;
STICKLINE(b0,0,-b0,5,0),Color008800;
STICKLINE(b0,0,-b0,3,0),Color00aa00;
STICKLINE(b0,0,-b0,1,0),Color00cc00;
周趋势:ma(a,5),ColorFFFFFF,PRECISION0;
平滑值:wma(周趋势,5),Color00FFFF,PRECISION0;
VERTLINE(量振1 and 标振1 and 周趋势>平滑值),COLORff00ff;
VERTLINE(量振2 and 标振2 and 周趋势<平滑值),COLOR00ff00;
DRAWTEXTEX(CLOSE,1,0,22,STKLABEL+' '+STKNAME+''),colorDDFF;
BB:=BARPOS=SYSPARAM(1);
VARIABLE:WDAY[7]='星期六';
WDAY[1]:='星期日';
WDAY[2]:='星期一';
WDAY[3]:='星期二';
WDAY[4]:='星期三';
WDAY[5]:='星期四';
WDAY[6]:='星期五';
FY:=YEAR;
FM:=MONTH;
FD:=DAY;
WD:=WEEKDAY;
P:=SYSPARAM(1);
STR1:=''+'今日: '+NUMTOSTR(FY[P],0)+'年'+NUMTOSTR(FM[P],0)+'月'+NUMTOSTR(FD[P],0)+'日 '+WDAY[WD[P]+1];
DRAWTEXTEX(CLOSE,1,460,22,STR1),colorDDFF;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD1:=2*(DIFF-DEA);
日转红:=MACD1>=0 AND REF(MACD1,1)<0;
CS1:=100;
CS2:=HHV(ABS(MACD1),CS1);
CS3:=ABS(100/CS2);
MACD:(MACD1*CS3+100)/2,LINETHICK3,color00FF00;
CS:=MACD;
日红:=CS>=REF(CS,1);
日转红:=日红 AND REF(日红,1)=0;
PARTLINE(日红,CS),LINETHICK3,colorred;
AA:=0;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((CLOSE-V1)/(V2-V1)*4,4);
DRAWTEXT(CROSS(价位线,0.3),AA,'买'),color0000FF;
DRAWTEXT(CROSS(3.7,价位线),AA,'卖'),colorFF00;
VERTLINE(CROSS(价位线,0.3)),color0000FF,LINEDASHDOT;
VERTLINE(CROSS(3.7,价位线)),colorFF00,LINEDASHDOT;

这个飞狐趋势为先指标公式是由公式指标网收集提供,更多的飞狐公式请你访问:http://gupiao.geren-jianli.org/category/fh/查看。