通达信公式-支撑与压力的神级主图指标公式

09/06/2019

局部低点预选A:=BACKSET(LLV(L,5)局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);
局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);
局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);
局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);
缺口判断:=IF(L>REF(H,1),1,IF(H距前高天:=BARSLAST(局部高点预选C=1);
距前低天:=BARSLAST(局部低点预选C=-1);
小值周期:=LOWRANGE(L);
大值周期:=TOPRANGE(H);
低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L预判:=IF((距前低天判断:=IF(局部高点预选C=1 AND REF(距前低天,1)REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)=4 OR HHV(缺口判断,距前低天)=1),1,0);
高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);
预判A:=IF((距前高天判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);
低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L距前高天A:=BARSLAST(高保留=1);
距前低天A:=BARSLAST(低保留=-1);
预判X:=IF((距前低天A判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)=4 OR HHV(缺口判断,距前低天A)=1),1,0);
高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);
预判XA:=IF((距前高天A判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);
低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L距前高天YA:=BARSLAST(高保留X=1);
距前低天YA:=BARSLAST(低保留X=-1);
预判YX:=IF((距前低天YA判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)=4 OR HHV(缺口判断,距前低天YA)=1),1,0);
高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);
预判YXA:=IF((距前高天YA判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);
低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND LAAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
XA:=DRAWLINE(极点保留=-1,L,REF(极点保留,1)=-1,REF(L,1),1);
XB:=DRAWLINE(极点保留=1,H,REF(极点保留,1)=1,REF(H,1),1);
XAS:=DRAWLINE(极点保留=-1,XB,REF(极点保留,1)=-1,REF(XB,1),1);
XBS:=DRAWLINE(极点保留=1,XA,REF(极点保留,1)=1,REF(XA,1),1);
XA45:=(XA+XAS)/2; XB45:=(XB+XBS)/2;
XA63:=(XAS-XA)*3/4+XA;XB63:=XB-(XB-XBS)*3/4;
DRAWBAND(XA45,RGB(0,150,100),XA63,RGB(0,150,100));
DRAWBAND(XB45,RGB(185,96,9),XB63,RGB(185,96,9));
局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)),CIRCLEDOT,COLORYELLOW,LINETHICK5;
压1:IF(BETWEEN(XA45,XB45,XB63),XA45,DRAWNULL),COLOR008800;
压2:IF(BETWEEN(XA63,XB45,XB63),XA63,DRAWNULL),COLOR008800;
过压底:REF(C,1)XA45 AND C过压顶:REF(C,1)XA63AND C支撑底:REF(C,1)XB63AND C支撑顶:REF(C,1)XB45AND CDRAWKLINE(HIGH,OPEN,LOW,CLOSE);
量5:=EMA(EMA(VOL,5),5);
量35:=EMA(EMA(VOL,35),35);
VAR11:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:=VOL;
主买:=IF(CLOSE>OPEN,VAR11*(HIGH-LOW),IF(CLOSE主卖:=IF(CLOSE>OPEN,VAR11*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE主买力度:=VOL/(主买-主卖);
买卖比:=主买/主卖;
昨日比:=买卖比/REF(买卖比,1);
净买: (主买-主卖)/100,NODRAW;
抢筹:=买卖比>4,NODRAW;
BB:=净买净买天数:BARSLAST(BB),COLORMAGENTA,NODRAW;
STICKLINE(净买>0,C,O,3,0),COLORRED;
STICKLINE(净买STICKLINE(抢筹,C,O,2,0),COLORYELLOW;
STICKLINE(主买力度>9,H,O,3,0),COLORWHITE;

这个通达信支撑与压力的神级主图指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。