通达信公式-操盘升级版主图指标公式

01/10/2019

强势:EMA((1+6/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,24))/MA(C,24)),2),DOTLINE,COLOR404040;
短趋:EMA(MA(CLOSE,7),2),DOTLINE,COLORBLUE;
趋势:=EMA(EMA(CLOSE,12),2);
强角:ATAN((强势/REF(强势,1)-1)*100)*57.3,NODRAW;
短角:ATAN((短趋/REF(短趋,1)-1)*100)*57.3,NODRAW;
趋角:ATAN((趋势/REF(趋势,1)-1)*100)*57.3,NODRAW;
角度:强角+短角+趋角,NODRAW;
涨停:=(C-REF(C,1))/REF(C,1)*100>9.88;
月涨停:COUNT(涨停,20),NODRAW,COLORYELLOW;
月创新高:COUNT(H=HHV(H,200),20),NODRAW,COLORCYAN;
历史新高:COUNT(H=HHV(H,0) OR C=HHV(C,0),20),NODRAW,COLORYELLOW;
上转峰:PEAK(H,6,1),NODRAW;
上2转峰:PEAK(H,6,2),NODRAW;
上3转峰:PEAK(H,6,3),NODRAW;
STICKLINE(C,上转峰,上转峰,4,0),COLOR404040;
STICKLINE(C,上2转峰,上2转峰,4,0),COLOR404040;
STICKLINE(C,上3转峰,上3转峰,4,0),COLOR404040;
突破:=CROSS(C,MAX(MAX(上转峰,上2转峰),MAX(上2转峰,上3转峰)));
突破1:=CROSS(C,PEAK(H,6,1)) AND CROSS(C,PEAK(H,6,2)) AND CROSS(C,PEAK(H,6,3)) AND C>强势;
趋强:=((强角+趋角)>120 OR 角度>230 OR REF(COUNT(涨停,3)>=2,1)) AND 强角>60;
创新高:=(H=HHV(H,400) AND C=HHV(C,400)) AND H>L AND REF(强角,1)>70 AND C>L AND C>REF(C,1);
涨停高开:=REF(涨停,1)=1 AND REF(H,1)=REF(HHV(H,200),1) AND O>REF(C,1) AND L>=REF(C,1) AND H>L AND C>O;
极强:=(角度>240 OR (角度>230 AND REF(COUNT(涨停,3)>=2,1))) AND C>强势 AND L>REF(L,1) AND C>O;
回调:=(REF(强角,1)>70 OR REF(COUNT(涨停,3)>=2,1)) AND L<强势*1.013 AND L>强势*0.97 AND C>强势 AND C>O;
回调短趋:=(REF(短角,1)+REF(强角,1))>110 AND L<=短趋*1.01 AND L>短趋*0.98 AND C>短趋 AND C>O;
博反弹:=(REF(H,1)=REF(HHV(H,400),1) OR REF(C,1)=REF(HHV(C,400),1)) AND (REF(H,1)-L)/REF(H,1)>0.14
AND L>短趋 AND REF(C,2)>REF(C,3) AND REF(角度,1)>200 AND 角度>150;
DRAWICON(突破,L*0.98,38);
DRAWICON(突破1,L*0.98,38);
DRAWICON(突破1,L*0.96,38);
DRAWICON(创新高,L*0.98,41);
DRAWICON(涨停高开,L*0.98,36);
DRAWICON(回调短趋,L*0.985,36);
DRAWICON(博反弹,L*0.975,1);
STICKLINE(趋强 OR 突破,REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.975,REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.95,3,0),COLORYELLOW;
STICKLINE(极强 OR 创新高 OR 涨停高开,REFDATE(REF(LLV(L,180)*0.95,3),DATE),REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.975,3,0),COLORRED;
STICKLINE(回调,O,C,1.5,0),COLORRED;
STICKLINE(回调,REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.975,REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.95,1.5,0),COLORRED;
STICKLINE(博反弹,REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.975,REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.95,3,0),COLORBLUE;
STICKLINE(H=HHV(H,0) OR C=HHV(C,0),REFDATE(REF(LLV(L,180)*0.95,3)*0.94,DATE),REFDATE(REF(LLV(L,180)*0.95,3),DATE)*0.92,3,0),COLORRED;
IF(强角+短角+趋角>150,强势,DRAWNULL),COLORRED,DOTLINE;
IF(强角+短角+趋角>150,短趋,DRAWNULL),COLORYELLOW,DOTLINE;
STICKLINE((C-REF(C,1))/REF(C,1)*100>9.8,O,C,0.5,0),COLORYELLOW;
STICKLINE((C-REF(C,1))/REF(C,1)*100<-9.8,O,C,0.5,0),COLORBLUE;
DRAWICON(H=HHV(H,200) OR C=HHV(C,200),H*1.009,37);
DRAWICON(H=HHV(H,400) OR C=HHV(C,400),H*1.009,36);
TA:=HORCALC(HYBLOCK,105,1,DRAWNULL);
TAA:=STRCAT(HYBLOCK,'排名 :');
DRAWTEXT_FIX(ISLASTBAR,0.73,0.85,0,STRCAT(TAA,CON2STR(TA,0))),COLORCYAN;
一日前:=REF(强角+短角+趋角,1),NODRAW;
二日前:=REF(强角+短角+趋角,2),NODRAW;
三日前:=REF(强角+短角+趋角,3),NODRAW;
四日前:=REF(强角+短角+趋角,4),NODRAW;
DRAWTEXT_FIX(1,0.86,0.79,1,STRCAT('',CON2STR(角度,0))),COLORYELLOW;
DRAWTEXT_FIX(1,0.83,0.79,1,STRCAT('',CON2STR(一日前,0))),COLORRED;
DRAWTEXT_FIX(1,0.8,0.79,1,STRCAT('',CON2STR(二日前,0))),COLOR0088FF;
DRAWTEXT_FIX(1,0.77,0.79,1,STRCAT('',CON2STR(三日前,0))),COLORWHITE;
DRAWTEXT_FIX(1,0.74,0.79,1,STRCAT('',CON2STR(四日前,0))),COLORBLUE;
DA:=YEAR AND MONTH AND DAY;
AAA:=STRCAT(CON2STR(YEAR,0),'年');
AAB:=STRCAT(CON2STR(MONTH,0),'月');
AA33:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT('【',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
AA:=STRCAT(STRCAT(STRCAT(AAA,AAB),STRCAT(AA33,AA4)),'】');
SA:DRAWTEXT_FIX(DA,0,0,0,AA),COLORWHITE;
DRAWTEXT_FIX(1,0.75,0.0,0,'涨停:'),COLORRED;
DRAWTEXT_FIX(1,0.81,0.0,0,'跌停:'),COLORGREEN;
DRAWNUMBER_FIX(1,0.78,0.0,0,CONST(BARSLAST(CLOSE/REF(CLOSE,1)>=1.095))),COLORRED;
DRAWNUMBER_FIX(1,0.84,0.0,0,CONST(BARSLAST(CLOSE/REF(CLOSE,1)<=0.9015))),COLORGREEN;

这个通达信操盘升级版主图指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。