通达信公式-整合MACD指标公式

05/30/2019

DIF:EMA(CLOSE,5)-EMA(CLOSE,11);
DEA:EMA(DIF,5);
MACD:(DIF-DEA)*2,COLORSTICK;
IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK1;
IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)> C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS
("MACD.DIF","MACD.DEA");
DRAWICON(B1>0,DIF*1.21,1);{底背离}
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));

D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)> "MACD.DIF" AND CROSS
("MACD.DEA","MACD.DIF");
DRAWICON(D1>0,DEA*1.21,2);{顶背离};
DRAWICON(CROSS(MACD,0),0,1);
DRAWICON(CROSS(0,MACD),0.2,2);
DRAWICON(CROSS(DIF,DEA),DIF,1),COLORRED;
DRAWICON(CROSS(DEA,DIF),DEA,2),COLORGREEN;

这个通达信整合MACD指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。