通达信公式-突破警戒线指标公式

03/23/2019

M1:=5;
M2:=10;
AAA:C;
M3:=EMA(CLOSE,5);
M20:=EMA(CLOSE,10);
A:=BARSLAST(CROSS(M3,M20));
A1:=REF(BARSLAST(CROSS(M3,M20)),A+1);
A2:=A+A1;
AA:=REF(BARSLAST(CROSS(M3,M20)),A2+2);
A3:=AA+A2;
B:=BARSLAST(CROSS(M20,M3));
B1:=REF(BARSLAST(CROSS(M20,M3)),B+1);
B2:=B+B1;
BB:=REF(BARSLAST(CROSS(M20,M3)),B2+2);
X1:=IF(A<B,A2-B,A-B);
Y1:=IF(A2<B2,A3-B2,A2-B2);
GD0:=REF(HHVBARS(H,X1+3),B);
GD1:=REF(HHVBARS(H,Y1+3),B2);
GG0:=BACKSET(ISLASTBAR,GD0+B+1);
GG1:=BACKSET(ISLASTBAR,GD1+B2+1);
TJ3:=CROSS(GG0,0.5);
TJ4:=CROSS(GG1,0.5);
上轨:=DRAWLINE(TJ4,H,TJ3,H,1);
值3:=GG0>REF(GG0,1);
值4:=GG1>REF(GG1,1);
顶1:IF(GG0,REF(HIGH,BARSLAST(值3)),0);
突破1:CROSS(C,顶1);
突破2:COUNT(突破1,10);
突破:(突破1 AND 突破2=1);

这个通达信突破警戒线指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。