飞狐公式-综合分析指标公式

01/25/2019

DRAWGBK((CLOSE > 0),COLORRGB(0,0,0),COLORRGB(0,0,0),1);
0,Color808080;
2,Color008000,POINTDOT;
4,Color008000,POINTDOT;
6,Color808080;
{KDJ}
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
STICKLINE("KDJ.J"<20,5,4.5,5,1),Color808040;
DRAWTEXT(CROSS(20,"KDJ.J"),4.8,'J<20'),Color80FFFF;
STICKLINE(B2>0,5,4,2,0),COLORRED;
DRAWTEXT(B2>0,4.4,'←底离'),COLORRED;
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
STICKLINE("KDJ.J">80,5,5.5,5,1),Color4080FF;
DRAWTEXT(CROSS("KDJ.J",80),5.4,'J>80'),ColorFFFF00;
STICKLINE(D2>0,5,6,2,0),COLORGREEN;
DRAWTEXT(D2>0,5.7,'←顶离'),COLORGREEN;
PARTLINE("KDJ.K">"KDJ.D",5),COLORMAGENTA,LINETHICK2;//KDJ指标线K>D,中轴为粉色
PARTLINE("KDJ.K"<"KDJ.D",5),ColorFF0000,LINETHICK2;//KDJ指标线K<D,中轴为蓝色
DRAWTEXTEX(C>0,1,1,10,'《KDJ指标》'),Color00A6A6;
{RSI}
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
STICKLINE("RSI.RSI1"<20,3,2.5,5,1),Color808040;
DRAWTEXT(CROSS(20,"RSI.RSI1"),2.8,'超卖'),Color80FFFF;
STICKLINE(B3>0,3,2,2,0),COLORRED;
DRAWTEXT(B3>0,2.4,'←底离'),COLORRED;

C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
STICKLINE("RSI.RSI1">80,3,3.5,5,1),Color4080FF;
DRAWTEXT(CROSS("RSI.RSI1",80),3.4,'超买'),ColorFFFF00;
STICKLINE(D3>0,3,4,2,0),COLORGREEN;
DRAWTEXT(D3>0,3.7,'←顶离'),COLORGREEN;
PARTLINE("RSI.RSI1">"RSI.RSI2",3),COLORMAGENTA,LINETHICK2;//RSI指标线RSI1>RSI2,中轴为粉色
PARTLINE("RSI.RSI1"<"RSI.RSI2",3),ColorFF0000,LINETHICK2;//RSI指标线RSI1<RSI2,中轴为蓝色
DRAWTEXTEX(C>0,1,1,350,'《RSI指标》'),Color00A6A6;
{MACD}
A1:=BARSLAST(ref(cross("MACD.diff","MACD.dea"),1));
B1:=ref(c,A1+1)>c and ref("MACD.diff",A1+1)<"MACD.diff" and cross("MACD.diff","MACD.dea");
STICKLINE("MACD.diff"<0,1,0.5,5,1),Color808040;
DRAWTEXT(CROSS(0,"MACD.diff"),0.8,'DIFF<0'),Color80FFFF;
STICKLINE(B1>0,1,0,2,0),COLORRED;
DRAWTEXT(B1>0,0.4,'←底离'),COLORRED;
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIFF"),1));
D1:=REF(CLOSE,C1+1)<CLOSE AND REF("MACD.DIFF",C1+1)>"MACD.DIFF" AND CROSS("MACD.DEA","MACD.DIFF");
STICKLINE("MACD.diff">0,1,1.5,5,1),Color4080FF;
DRAWTEXT(CROSS("MACD.diff",0),1.4,'DIFF>0'),ColorFFFF00;
STICKLINE(D1>0,1,2,2,0),COLORGREEN;
DRAWTEXT(D1>0,1.7,'←顶离'),COLORGREEN;
PARTLINE("MACD.diff">"MACD.dea",1),COLORMAGENTA,LINETHICK2;//MACD指标线DIFF>DEA,中轴为粉色
PARTLINE("MACD.diff"<"MACD.dea",1),ColorFF0000,LINETHICK2;//MACD指标线DIFF<DEA,中轴为蓝色
DRAWTEXTEX(C>0,1,1,680,'《MACD指标》'),Color00A6A6;//

这个飞狐综合分析指标公式是由公式指标网收集提供,更多的飞狐公式请你访问:http://gupiao.geren-jianli.org/category/fh/查看。