同花顺公式-看钟出招指标公式

07/10/2019

DRAWGBKLAST(CLOSE>0,STRIP(RGB(170,170,70),RGB(50,50,50),1));
看钟出招:7;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0);
VAR1:=SMA(最佳买入选股,3,1);
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
操底:=IF(CROSS(VAR2,VAR3) AND (VAR2<40),5,0* 10000);
吃肉:=CROSS(C,MA(C,3)) AND REF(C,2)<REF(MA(C,3),2);
VAR1:=MA((VOL-REF(VOL,1))/REF(VOL,1),5);
VAR2:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MY:=VAR2*(1+VAR1);
SHT:=MY;
SHTMA:=MA(SHT,5);
var3:=IF(CROSS(SHT,SHTMA)AND(SHTMA<0),23,0);
亮剑:=IF(var3>0,28,0);
WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
WSR2:=CROSS(WSR1,5);
WSR3:=CROSS(8,WSR1);
WSR4:=CROSS(WSR1,-5);
WSR5:=CROSS(WSR1,-8);
WSR6:=WSR3;
WSR7:=WSR4 OR WSR5;
出手:=WSR7 AND FILTER(WSR7,5);
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4));
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2));
飞镖:=CROSS(C1,C2) AND C2<60;
N:=9;
N1:=6;
M:=14;
TYP := (HIGH + LOW + CLOSE)/3;
CC1:=(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M));
C1:=SMA(CC1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
CB2:=REF(CB1,1);
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI:=(RSI1-50)*5;
R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
K1:=(K-50)*5;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
刀客:=RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100;
DRAWICON(操底>0,1.8,'buy');
DRAWICON(吃肉>0,2.8,'buy');
DRAWICON(亮剑>0,3.8,'buy');
DRAWICON(出手>0,4.8,'buy');
DRAWICON(飞镖>0,5.8,'buy');
DRAWICON(刀客>0,6.8,'buy');
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),1,'``操底'),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),2.5,'``吃肉'),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),3.5,'``亮剑'),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),4.5,'``出手'),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),5.5,'``飞镖'),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),6.5,'``刀客'),COLOR009fff;

这个同花顺看钟出招指标公式是由公式指标网收集提供,更多的同花顺公式请你访问:http://gupiao.geren-jianli.org/category/ths/查看。