大智慧公式-金兰换手指标公式

03/24/2019

实际V:VOL,LINETHICK0;
Var1:=DYNAINFO(17)*REF(MA(VOL,5),1);
Var2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
预测V1:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,Var1,Var2);
预测V:IF(实际V>=预测V1,实际V,预测V1),LINETHICK0;
流通盘:CAPITAL/1000000;
换手率:VOL/CAPITAL*100,LINETHICK0;
比:=预测V/实际V;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=(V9+V8)*比;
卖盘2:=(V6+V7)*比;
买盘:=IF(CATEGORY<>0 AND BARSTATUS=2 AND DATATYPE=6,买盘1,买盘2);
卖盘:=IF(CATEGORY<>0 AND BARSTATUS=2 AND DATATYPE=6,卖盘1,卖盘2);
STICKLINE(1,0,MAX(买盘,卖盘),1,0),COLORFFFFFF;
AADD:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
DRAWTEXTABS(5,5,' '),linethick1,COLOR00EEff;
买量:=IF(CLOSE>OPEN,AADD*(HIGH-LOW),IF(CLOSE<OPEN,AADD*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖量:=IF(CLOSE>OPEN,0-AADD*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AADD*(HIGH-LOW),0-VOL/2));
进出量:=买量+卖量;
红天3:=COUNT(进出量>0,3)=3;
红天5:=COUNT(进出量>0,5)=5;
红天9:=COUNT(进出量>0,9)=9;
DRAWICON(红天3,-400 ,4),ALIGN1;
净买:买盘-卖盘,COLORMAGENTA,LINETHICK0;
换手率:=VOL/CAPITAL*100;
hs:=换手率;
A:=MA(换手率,2);
X:=LLV(A,20);
X1:=(A-LLV(A,20))=0;
X2:=HHV(A,20);
X3:=(A-X2)=0;
换手率:=VOL/CAPITAL*100;
mv1:ema(v,9),Color0057FF;
mv2:ema(v,34),ColorF1910E;
FILLRGN(mv1,mv2,mv1>mv2),coloryellow;
FILLRGN(mv1,mv2,mv1<mv2),colorff9900;
STICKLINE(CLOSE<=REF(CLOSE,1) , VOL,0,8.5,1),Color00D400;
STICKLINE(CLOSE>REF(CLOSE,1), VOL,0,8.5,1),ColorBB00FF;
STICKLINE(净买>0,0,买盘,7,0),color102088;
STICKLINE(净买>0,0,买盘,6,0),color1020aa;
STICKLINE(净买>0,0,买盘,5,0),color1020bb;
STICKLINE(净买>0,0,买盘,4,0),color1020bb;
STICKLINE(净买>0,0,买盘,3,0),color1020dd;
STICKLINE(净买>0,0,买盘,2,0),color1020ee;
STICKLINE(净买<=0,0,买盘,7,0),color102088;
STICKLINE(净买<=0,0,买盘,6,0),color1020aa;
STICKLINE(净买<=0,0,买盘,5,0),color1020bb;
STICKLINE(净买<=0,0,买盘,4,0),color1020cc;
STICKLINE(净买<=0,0,买盘,3,0),color1020dd;
STICKLINE(净买<=0,0,买盘,2,0),color1020ee;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买>0,v,买盘,7,0),COLORFF7700;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买>0,v,买盘,6,0),COLORFF8811;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买>0,v,买盘,5,0),COLORFFAA22;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买>0,v,买盘,4,0),COLORFFBB33;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买>0,v,买盘,3,0),COLORFFDD44;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买>0,v,买盘,2,0),COLORFFFF55;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买<=0,v,买盘,7,0),COLORFF7700;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买<=0,v,买盘,6,0),COLORFF8811;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买<=0,v,买盘,5,0),COLORFFAA22;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买<=0,v,买盘,4,0),COLORFFBB33;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买<=0,v,买盘,3,0),COLORFFDD44;
STICKLINE(CLOSE>MA(CLOSE,30) AND 净买<=0,v,买盘,2,0),COLORFFFF55;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买>0,v,买盘,7,0),Color710000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买>0,v,买盘,6,0),ColorA10000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买>0,v,买盘,5,0),ColorC50000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买>0,v,买盘,4,0),ColorE50000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买>0,v,买盘,3,0),ColorFF6500;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买>0,v,买盘,2,0),ColorFFDB00;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买<=0,v,买盘,7,0),Color710000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买<=0,v,买盘,6,0),ColorA10000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买<=0,v,买盘,5,0),ColorC50000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买<=0,v,买盘,4,0),ColorE50000;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买<=0,v,买盘,3,0),ColorFF6500;
STICKLINE(CLOSE<MA(CLOSE,30) AND 净买<=0,v,买盘,2,0),ColorFFDB00;
stickline(换手率<1 ,V,0,2,0),colorff9900;
stickline(换手率>1 ,V,0,2,0),color00ff00;
stickline(换手率>3 ,V,0,2,0),coloryellow;
stickline(换手率>5,V,0,2,0),color0099ff;
stickline(换手率>10,V,0,2,0),Color0000FF;
DRAWTEXT(CROSS(mv1,mv2),v*1.2,'★买'),COLORYELLOW;
DRAWTEXT(CROSS(mv2,mv1),mv2*1.2,'↓卖'), colorff9900;

这个大智慧金兰换手指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。