通达信公式-新版135战法真金白银指标公式

11/06/2019

LOCK:=1;
M8:=EMA(CLOSE,8);
M13:=EMA(M8,13);
VAR1:=EMA(M13,62);VAR2:=(CLOSE+HIGH+LOW)/3;
VAR3:=EMA(VAR2,10)*LOCK;VAR4:=REF(VAR3,1)*LOCK;
天堂之路:STICKLINE(VAR3>VAR4,VAR3,VAR4,4,1),COLOR00FFFF;
地狱之门:STICKLINE(VAR3<VAR4,VAR3,VAR4,4,1),COLORFF0000;
MA13:MA(C,13),COLORRED,LINETHICK2;
K1:=BACKSET(MA13<REF(MA13,1),2);
十三:IF(K1,MA13,DRAWNULL),COLOR00CC33,LINETHICK2;
MA34:MA(C,34),COLORYELLOW,LINETHICK2;
K2:=BACKSET(MA34<REF(MA34,1),2);
三四:IF(K2,MA34,DRAWNULL),COLORFFCC66,LINETHICK2;
MA55:MA(C,55),COLOR9933CC,LINETHICK2;
K3:=BACKSET(MA55<REF(MA55,1),2);
五五:IF(K3,MA55,DRAWNULL),COLORBLUE,LINETHICK2;
阻力价:HHV(HIGH,19),LINETHICK1,NODRAW;
AR1:=MA55>MA34 AND MA34>MA13;
AR2:=BARSLAST((C-MA13)/MA13*100<-6);
AR3:=MA13>=REF(MA13,1);
AR4:=COUNT(CROSS(C,MA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
红杏出墙: DRAWTEXT(AR6,L-0.1,'←红杏'),COLORYELLOW;
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((MA13-MA34)+(MA34-MA55))/C<0.2;
BR3:=C>MA55 AND (REF(C,1)<REF(MA55,1) OR REF(C,2)<REF(MA55,2) OR
REF(C,3)<REF(MA55,3) OR REF(C,4)<REF(MA55,4) OR REF
(C,5)<REF(MA55,5));BR4:=BR1 AND BR2 AND BR3;
蚂蚁上树: DRAWTEXT(BR4 AND FILTER(BR4,10),H+0.3,'←上树'),COLOR00C5FF;
Y:=(MA(C,13)-MA(C,55))/MA(C,13)*100;
YY1:=C>MA(C,13) AND OPEN<MA(C,13);{一阳三线}
YY3:=C>MA(C,34) AND OPEN<MA(C,34);
YY5:=C>MA(C,55) AND OPEN<MA(C,55);
一阳穿三线: DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.1,'←穿三'),COLORRED;
SJ1:=ABS(MA(CLOSE,13)-MA(CLOSE,34))<C*0.01;{13线34线55线接近}
SJ2:=ABS(MA(CLOSE,34)-MA(CLOSE,55))<C*0.01;
SJ3:=CROSS(MA(CLOSE,13),MA(CLOSE,55));{13线上穿55线}
三军集结: DRAWTEXT(SJ1 AND SJ2 AND SJ3,HIGH+0.1,'←集结'),COLORRED;
RY1:=C/OPEN>1.04;{阳线4%}
RY2:=REF(OPEN,1)/REF(CLOSE,1)>1.04;{阴线4%}
RY3:=ABS(OPEN-REF(C,1))<C*0.02 AND ABS(C-REF(OPEN,1))<C*0.02;{两线相等}
日月合璧: DRAWTEXT(RY1 AND RY2 AND RY3 ,LOW,'←合璧'),COLORYELLOW;
HK1:=CROSS(MA(C,13),MA(C,55));{13线上穿55线}
HK2:=C<O;{当日收阴}
HK3:=ABS(L-MA(C,13))<C*0.03 OR ABS(C-MA(C,13))<C*0.04;{收盘价或最低价在13线}
HK:=HK1 AND HK2 AND HK3;
黑客点击: DRAWTEXT(HK,LOW,'←黑客'),COLORGREEN;
JG1:=ABS(MA(C,13)-MA(C,34))<C*0.02 AND ABS(MA(C,13)-MA(C,55))<C*0.02;
JG2:=O>MA(C,13) OR O=MA(C,13);
JG3:=C/OPEN>1.03 ; {阳线3%}
JG:=JG1 AND JG2 AND JG3;
揭竿而起: DRAWTEXT(JG,LOW-0.2,'←揭竿'),COLORYELLOW;
HY1:=CROSS(MA(C,13),MA(C,55));{13线上穿55线}
HY2:=OPEN<C AND C/OPEN>1.02; {阳线3%}
HY3:=ABS(OPEN-MA(C,13))<C*0.05;{开盘在13线附近}
HY:=HY1 AND HY2 AND HY3;
红衣侠女: DRAWTEXT(HY,LOW,'←侠女'),COLORRED;
JW1:=C<OPEN AND REF(C,1)<REF(OPEN,1);
JW2:=OPEN<REF(C,1) AND C>REF(L,1);
JW3:=O<MA(C,13) AND O<MA(C,34) AND O<MA(C,55);
JW:=JW1 AND JW2 AND JW3;
金屋藏娇: DRAWTEXT(JW,LOW-0.1,'←藏娇'),COLORYELLOW;
TS1:=CROSS(MA(C,13),MA(C,34));{13线上穿34线}
TS2:=MA(C,13)<MA(C,55);
TS:=TS1 AND TS2;
投石问路: DRAWTEXT(TS,LOW-0.2,'←投石'),COLORF00FF0;
MK1:=MA(C,13)>MA(C,55) AND MA(C,34)>MA(C,55);
MK:=TS1 AND MK1;
梅开二度: DRAWTEXT(MK,L-0.1,'←二度'),COLORF00FF0;
YZ1:=C/O>1.02 AND H/C>1.02 AND O/L<1.02;{收阳有上影}
YZ2:=REF(C,1)>REF(O,1) AND O>MA(C,11);{昨收阳 今大于均线}
YZ:=YZ1 AND YZ2 AND Y>10;
一支独秀: DRAWTEXT(YZ,HIGH+0.2,'←独秀'),COLORF00FF0;
DS1:=OPEN/C>1.04 AND O/REF(C,1)>1.03;{高开收阴}
DS2:=V*100/FINANCE(7)>0.08 AND Y>8;{换手高涨幅大}
DS:=DS1 AND DS2;
独上高楼: DRAWTEXT(DS,HIGH+0.0,'←高楼'),COLORGREEN;
YJ1:=H/O>1.04;
YJ2:=ABS(C-O)<C*0.03;
YJ3:=C/MA(C,13)>1.1;
YJ:=YJ1 AND YJ2 AND DS2 AND YJ3 AND YZ2;
一剑封喉: DRAWTEXT(YJ,HIGH+0.1,'←封喉'),COLORRED;
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) );
GR2:=MA13>MA34 AND MA34>MA55 AND MA13>REF(MA13,1);
GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
见好就收: DRAWTEXT(GR6 AND GR7,H+0.3,'←好收!'),COLOR00FF00;
T:=(MA(C,13)-MA(C,55))/MA(C,13)*100;
TT1:=C<MA(C,13) AND OPEN>MA(C,13);
TT3:=C<MA(C,34) AND OPEN>MA(C,34);
TT5:=C<MA(C,55) AND OPEN>MA(C,55);
一阴破三: DRAWTEXT(TT1 AND TT5 AND TT3,LOW-0.6,'←破三'),COLORRED;
阳克阴: DRAWTEXT(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>REF(OPEN,1),L-0.0,'←克阴'),COLORFF00FF;
阴克阳: DRAWTEXT(REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<REF(OPEN,1),H*1.01,'←克阳'),COLOR00FF00;
红箭1: DRAWICON(CROSS(MA13,MA34),MA34,1);
红箭2: DRAWICON(CROSS(MA13,MA55),MA55,1);
红箭3: DRAWICON(CROSS(MA34,MA55),MA55,1);
绿箭1: DRAWICON(CROSS(MA34,MA13),MA34,2);
绿箭2: DRAWICON(CROSS(MA55,MA13),MA55,2);
绿箭3: DRAWICON(CROSS(MA55,MA34),MA55,2);

这个通达信新版135战法真金白银指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。