通达信公式-全方位提示指标公式

08/13/2019

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,30);
多头排列:=CLOSE>MA1 AND MA1>MA2 AND MA2>MA3 AND MA3>MA4 AND CLOSE>OPEN;
MA60:=MA(C,60),COLORFFCC66; MA13:=MA(C,13),COLORFFCC66;
MA75:=MA(C,75),COLORFFCC66;
空头排列:=CLOSE<MA1 AND MA1<MA2 AND MA2<MA3 AND MA3<MA4 AND CLOSE<OPEN;
下跌趋势:=MA4<REF(MA4,3) ANDMA4<REF(MA4,1) ANDMA1<MA4;
上升趋势:=MA4>REF(MA4,3) ANDMA4>REF(MA4,1) ANDMA1>MA4;
下降成:=下跌趋势 AND MA1<REF(MA1,1) AND REF(NOT(下跌趋势),1);
上升成:=上升趋势 AND MA1>REF(MA1,1) AND REF(NOT(上升趋势),1);
一阴穿2线:=C/O<0.985 AND H>MA1 AND C<MA3;
一阳穿2线:=C/O>1.016 AND L<MIN(MA1,MA3)AND C>MAX(MA1,MA3);
发散度:=MA1/MA4;
均线下发散:=下跌趋势 AND 发散度<0.9 AND 发散度<0.99*REF(发散度,1);
均线上发散:=MA1>REF(MA1,1) AND MA2>REF(MA2,1) ANDMA3>REF(MA3,1) AND MA4>REF(MA4,1) AND MA1>MA2 AND MA2>MA3 AND MA3>MA4;
AAAA1:=MAX(MAX(MA(V,5),MA(V,10)),MA(V,60))/MIN(MIN(MA(V,5),MA(V,10)),MA(V,60))<=1.4;
AAAA2:=MAX(MA(C,5),MA(C,10))/MIN(MA(C,5),MA(C,10))<=1.4;
DIFF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIFF,9);
VARF:=LOW*0.9;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
均线密集:=DIFF>DEA AND K >D AND(MA5-MA10)<0.05 AND (MA20-MA5)<0.05 AND (MA10-MA5)<0.05 AND (MA5-MA20)<0.05;
A:=MA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),19);
B:=-100*(HHV(H,14)-C)/(HHV(H,14)-LLV(L,14));
DD:=EMA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),4);
长线:=A+100;
短线:=B+100;
中线:=DD+100;
见顶:=(REF(中线,1)>85 AND REF(短线,1)>85AND REF(长线,1)>65 AND CROSS(长线,短线));
顶区:=(中线 >REF(中线,1) AND REF(中线,1)>80 AND REF(短线,1)>95 OR REF(短线,2)>95
AND 长线>60 AND 短线<83.5 AND 短线<中线 AND 短线<长线+4);
底区:=长线<20 AND 中线<18 AND 短线<40 AND REF(短线,1)<5 AND 中线 >REF(中线,1)AND 短线 >REF(短线,1);
顶部:=FILTER(顶区,4);
STICKLINE(见顶,H,(H+L)/2,3,0), ,COLORRED;
STICKLINE(顶部,H,(H+L)/2,3,0), ,COLORRED;
VAR2N:=LLV(LOW,3)<=LLV(LOW,60);
VAR3N:=C>O AND (C/O>1.03 OR C>1.03*REF(C,1));
绝地反击:=IF(VAR2N AND VAR3N,90,0),COLORYELLOW,LINETHICK2;
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5));
GR2:=MA2>MA3 AND MA3>MA4 AND MA2>REF(MA2,1);
GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(9,17,8)<REF("MACD.MACD"(9,17,8),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
GR8:=GR6 AND GR7;
LC := REF(CLOSE,1);
RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
换手:=100*V/CAPITAL;
BB13:=ATAN(MA2-REF(MA2,1))*3.1416*10;
EMA8:=EMA(C,8);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,6)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,L*0.99,'买点'),COLOR00FF00;
高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H3:=高1-(高1-低1)*0.5;
轴:=REFDATE(H3,DATE)*0.7,POINTDOT,COLORLIGRAY,LINETHICK3;
中轴:=DYNAINFO(3)*1.2;
MACD:=4*(DIFF-DEA);
{STICKLINE(MACD>0,中轴,中轴+MACD,0,1),COLORRED;
STICKLINE(MACD<0,中轴,中轴+MACD,0,1),COLORLIBLUE; }
STICKLINE(MACD<REF(MACD,1)AND MACD>0,中轴,中轴+MACD,0,0 ),COLOR00BBFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,中轴,中轴+MACD,0,0 ),COLOR0011BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORBB11BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORFFBB11;
缩头:=IF(MACD>0 AND REF(MACD,1)>REF(MACD,2) AND MACD< REF(MACD,1),1,0);
缩脚:=IF(MACD<0 AND REF(MACD,1)< REF(MACD,2) AND MACD>REF(MACD,1),1,0);
DRAWICON( 缩脚,(中轴+MACD)-0.1,1),COLOR00FF00;
DRAWICON(FILTER(缩头,3) AND 缩头,(中轴+MACD)+0.1,2),COLORFF00FF;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100,COLORRED;
DRAWICON(SAT>=100 AND MACD>0,(中轴+MACD)+0.2,12);
ZDIF:=EMA(INDEXC,12)-EMA(INDEXC,26);
ZHIDEA:=EMA(ZDIF,9);
ZEMACD:=(ZDIF-ZHIDEA)*2/100,COLORSTICK;RC:=轴;DK:=ZEMACD;
STICKLINE(DK<REF(DK,1)AND DK>0,RC,RC+DK,0,0 ),COLOR00BBFF;
STICKLINE(DK>=REF(DK,1)AND DK>0,RC,RC+DK,0,0 ),COLOR0011BB;
STICKLINE(DK>REF(DK,1)AND DK<0,RC,RC+DK,0,0),COLORBB11BB;
STICKLINE(DK<=REF(DK,1)AND DK<0,RC,RC+DK,0,0),COLORFFBB11;
Z缩头:=IF(DK>0 AND REF(DK,1)>REF(DK,2) AND DK< REF(DK,1),1,0);
Z缩脚:=IF(DK<0 AND REF(DK,1)< REF(DK,2) AND DK>REF(DK,1),1,0);
DRAWICON( Z缩脚,(RC+DK)-0.1,1),COLOR00FF00;
DRAWICON(FILTER(Z缩头,3) AND Z缩头,(RC+DK)+0.1,2),COLORFF00FF;
个股趋势:=MA(C,1)/MA(REF(C,18),18)*100,COLOR33FF99,LINETHICK1;
大盘趋势:=EMA(INDEXC,1)/MA(REF(INDEXC,18),18)*100;
大盘走势:=MA(FORCAST(大盘趋势,20),6),COLORRED;
DPZD:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
GGZD:=(C-REF(C,1))/REF(C,1)*100;
QRD:=GGZD-DPZD;
强弱度:=EMA(QRD,20),COLORYELLOW;
穿:=CROSS(个股趋势,大盘趋势) AND 个股趋势>REF(个股趋势,2);
BDGD1:=HHV(J,2)=HHV(J,8) AND J>80;
BDDD:=LLV(J,2)=LLV(J,8);
J1向下拐头:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD1,1),1,0);
DRAWTEXT(J1向下拐头 ,HIGH*1.02,'J'),COLOR00FF00;
J1向上拐头:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,1,0);
DRAWTEXT(J1向上拐头,LOW*0.993,'J'),COLOR00FFFF;
买买:=IF(J<0,10,0);DRAWTEXT(CROSS(9.9,买买),LOW*0.95,'K'),COLORLIMAGENTA;
XS1:=MA(HIGH,5)*(1+5/100)*0.99;
DRAWTEXT(CROSS(C,XS1),H*1.03,'砸'),COLORWHITE;
TT:=240/FROMOPEN;
比:=TT;
J12:=(HIGH - ((HIGH - LOW) / 3));
J23:=(LOW + ((HIGH - LOW) / 3));
AAA1:=CONST(HHV(H,90));
BBB:=CONST(LLV(L,30))+2;
T1:=CONST(IF(CLOSE>=MA(CLOSE,13),1,0));
T2:=CONST(IF(CLOSE<MA(CLOSE,13) AND C<MA(CLOSE,5),1,0));
T3:=CONST(IF(C<MA75,1,0));
T4:=CONST(IF(CROSS(CLOSE,MA(CLOSE,13)),1,0));
T5:=CONST(IF(CROSS(MA(CLOSE,13),CLOSE),1,0));
T6:=CONST(IF((C>=MA5 AND C<MA13) ,1,0));
T7:=CONST(IF(C>=MA75,1,0));
T8:=CONST(IF(CROSS(C,XS1),1,0));
VAR1Y:=VOL/CAPITAL*100;
VAR2Y:=LLVBARS(LOW,10);
VAR3Y:=(CLOSE-REF(OPEN,VAR2Y))/REF(OPEN,VAR2Y)*100;
VAR4Y:=REF(CLOSE,2)*0.865;
VAR5Y:=REF(CLOSE,13)*0.772;
VAR6Y:=MAX(VAR4Y,VAR5Y);
T9:=(CLOSE-VAR6Y)/CLOSE>0.2 AND VAR3Y<50 AND SUM(VAR1Y,5)/5>5;
T10:=CONST(IF(VAR2N AND VAR3N,1,0));
T11:=CONST(IF(缩脚,1,0));
T12{M13}:=CONST(IF(ZEMACD>REF(ZEMACD,1) AND ZEMACD>0 AND ZDIF<0 ,1,0));
T13:=CONST(IF(ZEMACD<REF(ZEMACD,1) AND ZEMACD<0 ,1,0));
T14:=CONST(IF(上升趋势,1,0));
T15:=CONST(IF(ZEMACD>=REF(ZEMACD,1) AND ZEMACD>0 AND ZDIF>=0 ,1,0));
TS1:=IF(T1=1,0+0.03,0);
TS2:=IF(T2=1,TS1+0.04,TS1);
TS3:=IF(T3=1,TS2+0.04,TS2);
TS4:=IF(T4=1,TS3+0.04,TS3);
TS5:=IF(T5=1,TS4+0.04,TS4);
TS6:=IF(T6=1,TS5+0.04,TS5);
TS7:=IF(T7=1,TS6+0.04,TS6);
TS8:=IF(T8=1,TS7+0.04,TS7);
TS9:=IF(T9=1,TS8+0.035,TS8);
TS10:=IF(T10=1,TS9+0.04,TS9);
TS11:=IF(T11=1,TS10+0.04,TS10);
TS12:=IF(T12=1,TS11+0.04,TS11);
TS13:=IF(T13=1,TS12+0.04,TS12);
TS14:=IF(T14=1,TS13+0.04,TS13);
TS15:=IF(T15=1,TS14+0.04,TS14);
DRAWTEXT(T1=1 AND CURRBARSCOUNT=150,轴*1.4,'短线上升持股'),COLORRED ;
DRAWTEXT(T2=1 AND CURRBARSCOUNT=150,轴*1.4,'短线下降持币'),COLORGREEN;
DRAWTEXT(T3=1 AND CURRBARSCOUNT=150,轴*1.6,'长线下降持币'),COLORGREEN;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=28,轴*1.2,'加买点信号'),COLORRED;
DRAWTEXT(T5=1 AND CURRBARSCOUNT=28,轴*1.7,'今天是短线下降卖出信号'),COLORGREEN;
DRAWTEXT(T6=1 AND CURRBARSCOUNT=28,轴*1.3,'低买点持股信号'),COLORRED ;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=150,轴*1.6,'长线上升持股'),COLORRED ;
DRAWTEXT(T8=1 AND CURRBARSCOUNT=28,中轴*0.85,'阳线短卖信号,收盘或隔天卖,隔天买回'),COLORGREEN ;
DRAWTEXT(T9=1 AND CURRBARSCOUNT=28,中轴*0.85,'阳线卖点卖出'),COLORGREEN ;
DRAWTEXT(T11=1 AND CURRBARSCOUNT=28,轴*1.15,'缩脚,注意买人'),COLORGREEN ;
DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,轴*1.2,'大盘反弹,谨慎'),COLORWHITE ;
DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,轴*1.2,'大盘下降'),COLORWHITE ;
DRAWTEXT(T15=1 AND CURRBARSCOUNT=28,轴*0.9,'大盘上升趋势'),COLORWHITE ;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);MFI:=(HIGH-LOW)*1000000/(VOL*比);
绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);
M1:=CONST(IF(空头排列 AND 均线下发散,1,0));
M2:=CONST(IF(多头排列 AND 均线上发散,1,0));
M3:=CONST(IF(空头排列 AND NOT(均线下发散),1,0));
MM1:=CONST(IF(均线密集,1,0));
MM2:=CONST(IF(上升趋势 AND NOT(一阴穿2线) AND REF(上升趋势,1),1,0));
MM3:=CONST(IF(个股趋势<大盘趋势,1,0));
MM4:=CONST(IF(下跌趋势 AND REF(下跌趋势,1) AND NOT(一阳穿2线),1,0));
MM5:=CONST(IF(DIFF<0 AND MACD<=0 AND MACD>REF(MACD,1),1,0));
MM6:=CONST(IF((个股趋势>=大盘趋势),1,0));
MM7:=CONST(IF(ZEMACD>REF(ZEMACD,1) AND ZEMACD<0,1,0));
MM8:=CONST(IF(下跌趋势 AND REF(下跌趋势,1) AND NOT(一阳穿2线),1,0));
MM9:=CONST(IF(ZEMACD<REF(ZEMACD,1) AND ZEMACD>0,1,0));
量大:=(卖盘+买盘)/REF(VOL,1)>2;
M5:=CONST(量大);
量缩:=REF(VOL,1)/(卖盘+买盘)>1.5;
M6:=CONST(量缩);
卖量大:=(卖盘-买盘)/买盘>0.4;
M7:=CONST(卖量大);
买量大:=(买盘-卖盘)/卖盘>0.4;
M8:=CONST(买量大);
DRAWTEXT(M2 AND CURRBARSCOUNT=150,中轴*0.95,'均线多头发散,注意K线形态和股价节奏变化'),COLORGREEN;
DRAWTEXT(M7 AND CURRBARSCOUNT=55,BBB-(BBB*TS1)+1,'☆卖出量大于买入量40%以上;'),COLORGREEN;
DRAWTEXT(M8 AND CURRBARSCOUNT=55,BBB-(BBB*TS1)+0.5,'☆买入量大于卖出量40%以上'),COLORRED;
DRAWTEXT(MM1 AND CURRBARSCOUNT=70,中轴*0.9,'均线密集,注意方向变化'),COLORYELLOW;
DRAWTEXT(MM2 AND CURRBARSCOUNT=70,中轴*0.95,'处于上升趋势'),COLORYELLOW;
DRAWTEXT(MM3 AND CURRBARSCOUNT=150,轴*1.2,'个股弱于大盘走势'),COLORYELLOW;
DRAWTEXT(MM5 AND CURRBARSCOUNT=70,轴*1.25,'下跌趋势趋缓,可能转折'),COLORYELLOW;
DRAWTEXT(MM6 AND CURRBARSCOUNT=150,轴*1.2,'个股强于大盘走势'),COLORRED;
DRAWTEXT(MM7 AND CURRBARSCOUNT=70,轴*0.9,'大盘下跌趋缓'),COLORRED;
DRAWTEXT(DIFF<0 AND 缩头 AND CURRBARSCOUNT=28,轴*1.2,'短线反弹节束,警惕'),COLORRED ;
DRAWTEXT(MM9 AND CURRBARSCOUNT=28,轴*0.9,'大盘上升趋缓小心'),COLORGREEN;
DRAWTEXT(VAR2N AND VAR3N,L*0.99,'反击'),COLOR00FF00;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
STICKLINE(CROSS(BIAS,乖离)AND 乖离<-9,L*0.96,L*0.9,2,0),COLORRED;
STICKLINE( DK>REF(DK,1) AND DK<0 AND MACD>REF(MACD,1) AND MACD<0 AND REF(DK,2)<REF(DK,3), 中轴*0.99,RC*0.99,0,0 );
DRAWTEXT( DK>REF(DK,1) AND DK<0 AND MACD>REF(MACD,1) AND MACD<0 AND REF(DK,2)<REF(DK,3) AND CURRBARSCOUNT=28,轴*0.9,'共振买点,跟进'),COLORGREEN;
TY:=C;
X1:=REF(TY,5)=HHV(TY,2*5+1); Y1:=FILTER(X1,5); Z1:=BACKSET(Y1,5+1); HA:=FILTER(Z1,5);
X2:=REF(TY,5)=LLV(TY,2*5+1); Y2:=FILTER(X2,5); Z2:=BACKSET(Y2,5+1); LA:=FILTER(Z2,5);
短压力:=REF(C,BARSLAST(HA)),COLORMAGENTA,POINTDOT;
短支撑:=REF(C,BARSLAST(LA)),COLORGREEN,POINTDOT;
STICKLINE( CROSS(短支撑,C) , 中轴*0.995,轴*0.985,0,0 ),COLORGREEN;
DRAWTEXT(CROSS(短支撑,C) ,L*0.8,'止损'),COLORRED;
c;

这个通达信全方位提示指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。