大智慧公式-大牛勃起选股指标公式

03/05/2019

F:=EMA(C,10)-EMA(C,22);
A:=EMA(F,8);
MD:=(F-A)*2;
TOTAL:=IF(DATATYPE=1,5,IF(DATATYPE=2,15,IF(DATATYPE=3,30,IF(DATATYPE=4,60,IF(DATATYPE=5,240,1)))));
FROMOPEN:=if(CURRENTTIME>93000 and CURRENTTIME<150000,if(CURRENTTIME<113000,(TIMETOT0(CURRENTTIME)-34200)/60,if(CURRENTTIME>130000,(TIMETOT0(CURRENTTIME)-39600)/60,120)),240);
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:=IF(BARSTATUS=1,VOL*TOTAL/CTIME,VOL);
周期:=BARSLAST(CROSS(F,A) AND F<=0);
涨停因子1:=REF(COUNT((C-REF(C,1))/REF(C,1)*100>3 ,周期)>2,1) OR REF(COUNT((C-REF(C,1))/REF(C,1)*100>5 ,周期)>1,1) OR REF(COUNT((C-REF(C,1))/REF(C,1)*100>8 ,周期)>0,1);
涨停因子2:=VVOL>=REF(V,1)*1.382;
TZ1:=COUNT(REF(MD,1)<REF(MD,2),2)>=2 AND REF(MD,1)>=0 AND REF(F,1)>=0 AND MD>REF(MD,1) AND F>REF(F,1);
TZ2:=COUNT(REF(MD,1)<REF(MD,2),2)>=2 AND REF(MD,1)<=0 AND REF(F,1)>=0 AND MD>0 AND F>REF(F,1);
TZ3:=COUNT(REF(MD,1)<REF(MD,2),2)>=2 AND REF(MD,1)<=0 AND REF(F,1)<=0 AND MD>0 AND F>0;
TZ4:=COUNT(REF(MD,1)<REF(MD,2),2)>=2 AND REF(MD,1)<=0 AND REF(F,1)<=0 AND MD>REF(MD,1) AND F>0;
TZ5:=COUNT(REF(MD,1)<REF(MD,2),2)>=2 AND REF(MD,1)>=0 AND REF(F,1)<=0 AND MD>REF(MD,1) AND F>REF(F,1);
TZ6:=COUNT(REF(MD,1)<REF(MD,2),2)>=2 AND REF(MD,1)<=0 AND REF(F,1)<=0 AND MD>0 AND F>REF(F,1);
XG1:=涨停因子1 AND 涨停因子2 AND TZ1;
XG2:=涨停因子1 AND 涨停因子2 AND TZ2;
XG3:=TZ3;
XG4:=涨停因子1 AND 涨停因子2 AND TZ4;
XG5:=涨停因子1 AND 涨停因子2 AND TZ5;
XG6:=涨停因子1 AND 涨停因子2 AND TZ6;
DRAWICON(XG1 OR XG2 OR XG3 OR XG4OR XG5 OR XG6,5,7);
大牛:if(XG1 OR XG2 OR XG3 OR XG4OR XG5 OR XG6,7,0);
DRAWTEXT(大牛,大牛,'大牛'),COLORYELLOW;

这个大智慧大牛勃起选股指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。