通达信公式-黄金分割分时主图指标公式

05/15/2019

DRAWTEXT_FIX(1,0.09,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.18,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.27,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.36,0,0,DYBLOCK)COLOR00FFFF;
MA30:=EMA(CLOSE,30);
强弱界定:EMA(CLOSE,900);
STICKLINE((MA30>强弱界定),MA30,强弱界定,1,0),COLOR0000FF;
STICKLINE((MA30<强弱界定),MA30,强弱界定,1,0),COLOR00FF00;
DRAWICON(CROSS(MA30,强弱界定),H,1);
AAA:DYNAINFO(5),COLORDDAADD,LINETHICK1;{最高}
BBB:DYNAINFO(6),COLOR888800,LINETHICK1;{最低}
CCC:=AAA-BBB;
中G:(AAA+BBB)/2,COLOR999999,LINETHICK1;{中}
上顶:BBB+CCC*7/8,COLOR008800,DOTLINE;
阻力:BBB+CCC*2/3,COLOR777700,DOTLINE;
支撑:BBB+CCC/3,COLOR777700,DOTLINE;
下底:BBB+CCC*1/8,COLOR447777,DOTLINE;
JJA:=C,COLOR999999,LINETHICK2;
支撑2:BBB+CCC*0.5/8,DOTLINE,COLOR00DD00;
DRAWNUMBER(CURRBARSCOUNT=12,AAA*0.9995,AAA),COLORFFAAFF;
DRAWNUMBER(CURRBARSCOUNT=12,BBB,BBB),COLORDDDD00;
DRAWNUMBER(CURRBARSCOUNT=12,中G,中G),COLORDDDDDD;
DRAWNUMBER(CURRBARSCOUNT=12,上顶,上顶),COLOR00FFFF;
DRAWNUMBER(CURRBARSCOUNT=12,阻力,阻力),COLOR00FFFF;
DRAWNUMBER(CURRBARSCOUNT=12,支撑,支撑),COLOR00FFFF;
DRAWNUMBER(CURRBARSCOUNT=12,下底,下底),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=20,AAA*0.9995,'最高:'),COLORFFAAFF;
DRAWTEXT(CURRBARSCOUNT=20,BBB,'最低:'),COLORFFFF00;
DRAWTEXT(CURRBARSCOUNT=20,上顶,'上顶:'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=20,阻力,'阻力:'),COLORFFFF00;
DRAWTEXT(CURRBARSCOUNT=20,支撑,'上支撑:'),COLORFFFF00;
DRAWTEXT(CURRBARSCOUNT=20,下底,'下底:'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=20,中G,'平衡:'),COLOREEEEEE;
{DRAWTEXT(CURRBARSCOUNT=20,强弱界定,'强弱界定:'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=20,支撑2,'下支撑:'),COLOREEEEEE;}
VAR1:=EMA(EMA(C,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
无庄控盘:=控盘<0;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR2:=100*WINNER(C*0.95);
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
高度控盘:=VAR2>50 AND COST(85)<C AND 控盘>0;
A10:=CROSS(控盘,0);
控盘B:=FILTER(IF(A10,1,0),5);
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
DRAWTEXT(CROSS(JJA,支撑2) AND 控盘<-0.2,强弱界定*0.995,'★有庄'),COLORMAGENTA,LINETHICK5;
A25:=HHVBARS(CLOSE,60);
突破1:=FILTER(((CROSS(CLOSE,((REF(REF(CLOSE,A25),1))*1.001)))AND(REF((A25>= 5),1))),10),POINTDOT,LINETHICK0;
STICKLINE(突破1,AAA,BBB,1,0),COLORF600A9;
DRAWTEXT( 突破1,中G-0.02,'★突破'),COLORF600A9;
DRAWTEXT((((SUM((突破1>0),0))=1)AND 突破1),(CLOSE*0.99),'最佳买点'),COLORWHITE;
DRAWTEXT((((SUM((突破1>0),0))=2)AND 突破1),(CLOSE*0.99),'次佳买点'),COLORWHITE;
DRAWTEXT((((SUM((突破1>0),0))=3)AND 突破1),(CLOSE*0.99),'理想买点'),COLORWHITE;
DRAWTEXT((((SUM((突破1>0),0))=4)AND 突破1),(CLOSE*0.99),'及格买点'),COLORWHITE;
DRAWTEXT((((SUM((突破1> 0),0))>=5) AND 突破1),(CLOSE * 0.99),'突破'),COLORWHITE;
JJ:=SUM(C*V,0)/SUM(V,0),COLOR00FFFF;
LC:= REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
GB:IF(RSI1>80,H*1.0005,DRAWNULL),CIRCLEDOT,LINETHICK5,COLORFFFF00;
GBB:IF(RSI1>84,H*1.0008,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;
均:SUM(CLOSE*VOL,FROMOPEN)/SUM(VOL,FROMOPEN),COLORYELLOW,DOTLINE;

这个通达信黄金分割分时主图指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。