大智慧公式-心悦诚服主图指标公式

05/14/2019

input:N(10,0,90);
DRAWTEXTREL(10,15,'★可调【买卖标记:N='+N+', [0---不显示,优化:个股N=20,大盘N=30]】'),COLOR00FFFF,linethick2;
{K线}
STICKLINE(CLOSE>OPEN,HIGH,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,HIGH,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;
{卖黄金,RSI=80}
LC:=REF(C,1);
卖黄金:((SMA(MAX((C - LC),0),3,1) / SMA(ABS((C - LC)),3,1)) * 100),LINETHICK0;
STICKLINE(CROSS(80,卖黄金) AND C<O,H,L,2,0),COLOR00ffff,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND C<O,C,O,12,0 ),COLOR007777,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND C<O,C,O,8,0 ),COLOR009999,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND C<O,C,O,6,0 ),COLOR00BBBB,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND C<O,C,O,4,0 ),COLOR00DDDD,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND C<O,C,O,2 ,0 ),COLOR00ffff,LAYER0;
{心悦诚服}
BBI:=(2*C+H+L+O/2)/4.5;
心悦:EMA(((SLOPE(BBI,18)*21)+C),43),COLOR00FF00,LINETHICK1;
PARTLINE(心悦,心悦>ref(心悦,1),rgb(255,0,0)),LINETHICK3,LAYER3;

阻拦:EMA(REF(HHV(H*0.987,30),1),2),COLOR0077FF;
支护:EMA(REF(LLV(L*1.013,30),1),2),COLOR99ff99;
FILLRGN(阻拦,心悦,阻拦>心悦,RGB(0,80,0)),COLORFF9900,LAYER7;
FILLRGN(支护,心悦,支护<心悦,RGB(50,0,30)),COLOR00FF00,LAYER7;
FILLRGN(阻拦,支护,心悦>ref(心悦,1),RGB(0,0,255)),COLORFF9900,LAYER5;
诚服:WMA(BBI,8),COLOR00FFFF,PRECIS2;
{买卖标记}
A3:=REF(H,N)=HHV(H,2*N+1);
B3:=FILTER(A3,N);
C3:=BACKSET(B3,N+1);
D3:=FILTER(C3,N);{高点}
A4:=REF(L,N)=LLV(L,2*N+1);
B4:=FILTER(A4,N);
C4:=BACKSET(B4,N+1);
D4:=FILTER(C4,N);{低点}
drawbmp(D3 or (D3 AND C<O AND VOL>MA(VOL,5) AND VOL>MA(VOL,60)),(H)*1.04,'LC.bmp'),align1,layer0;
drawbmp(D4 or (D4 AND C>OAND VOL>ref(LLV(VOL,60),1)),(l)*0.99,'LR.bmp'),align1,layer0;

这个大智慧心悦诚服主图指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。