牛熊三色完美优化指标(通达信公式-)

12/20/2019

EXPMA1:=EXPMA(CLOSE,7);
EXPMA2:=EXPMA(CLOSE,21);
N:=4;
S:=2;
M:=20;

高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H3:=高1-(高1-低1)*0.5;
中轴:=REFDATE(H3,DATE),LINETHICK1;
B1:=EMA(C,12);
B2:=EMA(C,26);
B3:=(B1-B2)*2;
WDIF:=中轴+B3;
WDEA:=EMA(WDIF,9);
MACD:=2*(WDIF-WDEA);

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

STICKLINE(MACD>0,0,1,0,1),COLORRED;
STICKLINE(MACD<0,0,1,0,1),COLORGREEN;
STICKLINE(EXPMA1>EXPMA2,1,2,0,1),COLORRED;
STICKLINE(EXPMA1<EXPMA2,1,2,0,1),COLORGREEN;
STICKLINE(CLOSE>SAR(N,S,M),2,3,0,1),COLORRED;
STICKLINE(CLOSE<SAR(N,S,M),2,3,0,1),COLORGREEN;

STICKLINE("KDJ.J" >100,3,4,0,1),COLORGREEN;
STICKLINE("KDJ.J" <0,3,4,0,1),COLORRED;
STICKLINE(CCI>200,4,5,0,1),COLORGREEN;
STICKLINE(CCI<-200,4,5,0,1),COLORRED;

DRAWTEXT(ISLASTBAR,0.5,'MACD'),COLOR0089FF;
DRAWTEXT(ISLASTBAR,1.5,'EXPMA'),COLOR0089FF;
DRAWTEXT(ISLASTBAR,2.5,'SAR'),COLOR0089FF;
DRAWTEXT(ISLASTBAR,3.5,'KDJ'),COLOR0089FF;
DRAWTEXT(ISLASTBAR,4.5,'CCI'),COLOR0089FF;

用法注释:判断股票运行趋势强弱的方法,被称为“牛熊三色”,牛熊三色每翻红一色,就可以增加1/3的仓位,三色全翻红的时候基本可以满仓。这三色分别是:
SAR指标 红色的时候第1行翻红 反之翻绿
EXPMA指标 EXPMA(7)大于 EXPMA(21)的时候 第2行翻红反之翻绿
MACD指标红柱的时候第3行翻红反之翻绿

追加优化部分
1)KDJ>100 翻绿(表示超买了可以高抛了) KDJ<0 翻红 (表示超卖了可以抄底了) 在(0-100)之间默认颜色,表示正常
1)CCI>200 翻绿(表示超买了可以高抛了)CCI<-200 翻红 (表示超卖了可以抄底了)在 (负200 - 正200)之间默认颜色,表示正常

这个牛熊三色完美优化指标(通达信)是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。