同花顺公式-趋势MS线主图指标公式

12/12/2019

使用时请叠加在主图K线上。出现黄色柱状线为多头市场,后势上涨概率较大;出现蓝色柱状线为空头市场,后势下跌风险较大。上升趋势对于持股阶段,下跌阶段对应持币阶段。

N:=20;
M:=32;
P1:=80;
P2:=100;
VAR1:=(C+H+O+L)/4;
MA1:=MA(VAR1,3);
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
STICKLINE(买,OPEN,CLOSE,2,0),coloryellow;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
STICKLINE(A>B,A,B,2,0),coloryellow;
STICKLINE(A<B,A,B,2,0),colorgreen;
B:=FORCAST(C,21);
Var10:=(3*CLOSE+LOW+OPEN+HIGH)/6;
天:(20*Var10+19*REF(Var10,1)+18*REF(Var10,2)+17*REF(Var10,3)+16*REF(Var10,4)+15*REF(Var10,5)+14*REF(Var10,6)+13*REF(Var10,7)+12*REF(Var10,8)+11*REF(Var10,9)+10*REF(Var10,10)+9*REF(Var10,11)+8*REF(Var10,12)+7*REF(Var10,13)+6*REF(Var10,14)+5*REF(Var10,15)+4*REF(Var10,16)+3*REF(Var10,17)+2*REF(Var10,18)+REF(Var10,20))/210,colorwhite;
地:MA(天,13),colorwhite;
合:EMA(天,7),colorwhite;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲'),colorred;
DRAWTEXT(CROSS(X,Y),(HIGH * 1.015),''),colorFF6699;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);
VAR6:=((AK + VAR5) / 2);
VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT((CD = 0.6),(LOW * 0.99),''),LINETHICK5,colorFFFFFF;
DRAWTEXT((AB = 1),(LOW * 0.99),''),LINETHICK5,color33CC99;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(bu,LOW,''),ALIGN1,VALIGN0,Color208FFF;

这个同花顺趋势MS线主图指标公式是由公式指标网收集提供,更多的同花顺公式请你访问:http://gupiao.geren-jianli.org/category/ths/查看。