通达信公式-趋势黄金分割划线主图及选股指标公式

12/11/2018

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH);
LL:=CONST(REF(L,JD));
黄金线:IF(CURRBARSCOUNTIF(CURRBARSCOUNTIF(CURRBARSCOUNTEXT1:DRAWLINE(QD,H,ZD,H,1),DOTLINE,COLORYELLOW;
STICKLINE(QD,H,L,0,0),COLORYELLOW;
STICKLINE(QD,C,O,2,0),COLORYELLOW;
STICKLINE(ZD,H,L,0,0),COLORLIRED;
STICKLINE(ZD,C,O,2,0),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=CONST(YH)+10,CONST(HH),VARCAT(VARCAT('远高价',VAR2STR(CONST(HH),2)),'元')),COLORYELLOW;
DRAWTEXT(ZD,H*1.02,VARCAT(VARCAT('近高价',VAR2STR(H,2)),'元')),COLORLIRED;
DRAWICON(CROSS(C,EXT1) AND CURRBARSCOUNTDRAWICON(CROSS(C,黄金线) AND CURRBARSCOUNT

{
选股公式1:突破黄金线选股

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
黄金线:=IF(CURRBARSCOUNTCROSS(C,黄金线) AND CURRBARSCOUNT}

{
选股公式2:突破黄色趋势线选股

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
EXT1:=DRAWLINE(QD,H,ZD,H,1);
CROSS(C,EXT1) AND CURRBARSCOUNT}

这个通达信趋势黄金分割划线主图及选股指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。