大智慧公式-德马克主图指标公式

07/12/2019

a:="[email protected]";
R1:="[email protected]_RISK1";
R2:="[email protected]_RISK2";
S1:="[email protected]_STS1";
S2:="[email protected]_STS2";
TBS:="[email protected]_STSBS";
DN:="[email protected]_STSDN";
UP:="[email protected]_STSUP";
压力位:UP,linethick0,color0000ff,PRECIS2;
支撑位: DN,linethick0,color00ff00,PRECIS2;
警示位:IF(R1<>0,ABS(R1),IF(R2<>0,ABS(R2),0)),linethick0,colorff00ff,PRECIS2;
红轨道:MA(MA(CLOSE,3),1),LINETHICK2,COLOR0000FF;
绿轨道:MA(MA(CLOSE,3),3),LINETHICK2,COLOR00FF00;
DRAWLINE(UP>0,UP,UP<>REF(UP,1) OR C=DYNAINFO(7),REF(ABS(UP),1),0),dotline,color0000ff,LINETHICK1;
DRAWLINE(DN>0,DN,DN<>REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),dotline,color00ff00,LINETHICK1;
DRAWLINE(UP<0,-UP,UP<>REF(UP,1) OR C=DYNAINFO(7),REF(ABS(UP),1),0),color0000ff;
DRAWLINE(DN<0,-DN,DN<>REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),color00ff00;
DRAWLINE(R1>0,R1,R1<>REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),dotline,colorEE88ff;
DRAWLINE(R2>0,R2,R2<>REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),dotline,colorEE88ff;
DRAWLINE(R1<0,-R1,R1<>REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),colorEE88ff;
DRAWLINE(R2<0,-R2,R2<>REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),colorEE88ff;

drawbmp(TBS=1,l*0.96,'STSbuy1.bmp'),align1,valign0;
drawbmp(TBS=-1,h*1.07,'STSsell1.bmp'),align1,valign0;
drawbmp(S2=14,l*0.94,'STSbuy.bmp'),align1,valign0;
drawbmp(S2=-14,h*1.09,'STSsell.bmp'),align1,valign0;
drawtext(S1>0,L,STR(S1)),color00FF00,LINETHICK1,align1,valign0;
drawtext(S1<0,H*1.03,STR(-S1)),color00FF00,LINETHICK1,align1,valign0;
drawtext(S2>0 and S2<13,l*0.97,STR(S2)),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2<0 and S2>-13,H*1.06,STR(-S2)),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=13,l*0.97,'+'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=14,l*0.97,'13'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=-13,h*1.06,'+'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=-14,h*1.06,'13'),color0000FF,LINETHICK1,align1,valign0;
b:="[email protected]";
s11:="[email protected]_S1";
hs:="[email protected]_HS";
ls:="[email protected]_LS";
p1:="[email protected]_P1";
upp:="[email protected]_UPP";
udd:="[email protected]_UDD";
d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s11=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点n','若明日收盘价>'+numtostrn(upp,2)+',出现B点n');
tr1:=ifs(s11=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s11=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';
bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'买卖点决策系统提示n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+tr4;
drawflagtext(1,fb,bs);
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c) <3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c) <3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c) <3) and c>=o,l,o,0.5,1),colorffff54;
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;

这个大智慧德马克主图指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。