大智慧公式-3D量柱群指标公式

05/02/2019

交易量:VOL,VOLSTICK;
MA5:MA(VOL,5)*2;{*2是将均线提高显示高度}
MA10:MA(VOL,10)*2;
MA20:MA(VOL,20)*2;
ii:=COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
T:=DYNAINFO(8)>0;
VO:=VOL=LLV(VOL,100) AND T;
地量柱:T AND VO,colorff5500;
BLZ:=VOL>REF(V,1)*1.9;
BLZ1:=VOL<REF(LLV(VOL,13),1);
BLZ2:=VOL<REF(LLV(VOL,55),1);
倍量柱:BLZ,color0000CD;
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,3),color00FFFF;
价涨量缩:ii,COLOR00DD00;
FLZ:=V>REF(V,1)*0.98 AND V<REF(V,1)*1.02;
平量柱:FLZ,COLORMAGENTA;
{画红色柱线}
STICKLINE(C>=O,0,V,8,0),color0000A3;
STICKLINE(C>=O,0,V,7,0),color0000B7;
STICKLINE(C>=O,0,V,6,0),color0000CD;
STICKLINE(C>=O,0,V,5,0),color0000E9;
STICKLINE(C>=O,0,V,3,0),color0754E9;
STICKLINE(C>=O,0,V,1,0),color076EF3;
{画蓝色柱线}
STICKLINE(C<O,0,V,8,0),COLOR888800;
STICKLINE(C<O,0,V,6,0),COLORAAAA00;
STICKLINE(C<O,0,V,3.2,0),COLORDDDD00;
STICKLINE(C<O,0,V,1.2,0),COLORFFFF00;
{阳倍量柱(上半部)}
STICKLINE(倍量柱 and C>O,(V)/2,V,8,0),color070084;
STICKLINE(倍量柱 and C>O,(V)/2,V,7,0),color0000A3;
STICKLINE(倍量柱 and C>O,(V)/2,V,6,0),color0000B7;
STICKLINE(倍量柱 and C>O,(V)/2,V,5,0),color0000CD;
STICKLINE(倍量柱 and C>O,(V)/2,V,4,0),color0000E9;
STICKLINE(倍量柱 and C>O,(V)/2,V,3,0),color0754E9;
STICKLINE(倍量柱 and C>O,(V)/2,V,1,0),color076EF3;
{阳倍量柱(下半部银色)}
STICKLINE(倍量柱 and C>O,O,(V)/2,8,0),color333333;
STICKLINE(倍量柱 and C>O,O,(V)/2,7,0),color555555;
STICKLINE(倍量柱 and C>O,O,(V)/2,6,0),color777777;
STICKLINE(倍量柱 and C>O,O,(V)/2,5,0),color999999;
STICKLINE(倍量柱 and C>O,O,(V)/2,4,0),colorbbbbbb;
STICKLINE(倍量柱 and C>O,O,(V)/2,2,0),colordddddd;
STICKLINE(倍量柱 and C>O,O,(V)/2,1,0),colorffffff;
{倍量黄金柱(上半部蓝色)}
STICKLINE(黄金柱 and C>O,(V)/2,V,8,0),color0090FF;
STICKLINE(黄金柱 and C>O,(V)/2,V,7,0),color009FFF;
STICKLINE(黄金柱 and C>O,(V)/2,V,6,0),color00B5FF;
STICKLINE(黄金柱 and C>O,(V)/2,V,5,0),color00E4FF;
STICKLINE(黄金柱 and C>O,(V)/2,V,4,0),color00FFFF;
STICKLINE(黄金柱 and C>O,(V)/2,V,3,0),color00FFFF;
STICKLINE(黄金柱 and C>O,(V)/2,V,1,0),color00FFFF;
{画黄色阳K线}
STICKLINE(地量柱,0,V,8,0),colorff3300;
STICKLINE(地量柱,0,V,7,0),colorff5500;
STICKLINE(地量柱,0,V,6,0),colorff7700;
STICKLINE(地量柱,0,V,5,0),colorff9900;
STICKLINE(地量柱,0,V,3,0),colorffbb00;
STICKLINE(地量柱,0,V,5,0),colorffdd00;
{画粉色K线}
STICKLINE(FLZ,0,V,8,0),colorff33ff;
STICKLINE(FLZ,0,V,7,0),COLORFF55FF;
STICKLINE(FLZ,0,V,6,0),COLORFF77FF;
STICKLINE(FLZ,0,V,5,0),colorff99ff;
STICKLINE(FLZ,0,V,3,0),colorffbbff;
STICKLINE(FLZ,0,V,1.5,0),colorffddff;
{画阴倍量柱线上半部}
STICKLINE(倍量柱 AND C<O,(V)/2,V,8,0),COLOR888800;
STICKLINE(倍量柱 AND C<O,(V)/2,V,6,0),COLORAAAA00;
STICKLINE(倍量柱 AND C<O,(V)/2,V,3.2,0),COLORDDDD00;
STICKLINE(倍量柱 AND C<O,(V)/2,V,1.2,0),COLORFFFF00;
{阴倍量柱(下半部银色)}
STICKLINE(倍量柱 AND C<O,O,(V)/2,8,0),color333333;
STICKLINE(倍量柱 AND C<O,O,(V)/2,7,0),color555555;
STICKLINE(倍量柱 AND C<O,O,(V)/2,6,0),color777777;
STICKLINE(倍量柱 AND C<O,O,(V)/2,5,0),color999999;
STICKLINE(倍量柱 AND C<O,O,(V)/2,4,0),colorbbbbbb;
STICKLINE(倍量柱 AND C<O,O,(V)/2,2,0),colordddddd;
STICKLINE(倍量柱 AND C<O,O,(V)/2,1,0),colorffffff;
{价涨量缩绿色柱}
STICKLINE(ii,0,V,8,0),COLOR008800;
STICKLINE(ii,0,V,4,0),COLOR00AA00;
STICKLINE(ii,0,V,3.2,0),COLOR00DD00;
STICKLINE(ii,0,V,1.2,0),COLOR00FF00;

这个大智慧3D量柱群指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。