大智慧公式-周期过滤指标公式

04/06/2019

input:周期(15,1,100),过滤(8,1,100),选股(-26,-30,-20),抄底(-40,-50,-25);
售价万元:0, POINTDOT;
Var2:=MA(CLOSE, 5);
Var3:=MA(CLOSE, 10);
Var4:=MA(CLOSE, 20);
Var5:=MA(CLOSE, 30);
Var6:=(Var2+Var3+Var4+Var5)/4;
Var7:=(Var6-REF(Var6, 周期))/REF(Var6, 周期)*100;
Var8:=(Var6-REF(Var6, 周期))/REF(Var6, 周期)*100;
Var9:=EMA(Var7, 过滤);
反转:STICKLINE(Var9>1*REF(Var9, 1), Var7, 0, 5, 0), COLOREE00EE;
持股:STICKLINE(Var7>1*REF(Var7, 1), Var7, Var9, 5, 0), COLORRED;
持币:STICKLINE(Var7<1*REF(Var7, 1), Var7, Var9, 5, 1), COLORGREEN;
洗盘:STICKLINE(Var7<1*REF(Var7, 1) AND Var9>1*REF(Var9, 1), Var7, Var9, 10, 0), COLOR00EEFF;

Var10:=(CLOSE-MA(CLOSE, 58))/MA(CLOSE, 58)*100;
Var11:=(Var10>1*REF(Var10, 1) AND Var10<选股 AND Var10>抄底)*1.5;
Var12:=VOL/CAPITAL*100;
Var13:=LLVBARS(LOW, 50);
Var14:=SUM(VOL, Var13);
Var15:=HHVBARS(HIGH, 50);
Var16:=SUM(VOL, Var15);
Var17:=(CLOSE-REF(OPEN, Var15))/REF(OPEN, Var15)*100;
Var18:=Var16/CAPITAL*100;
Var19:=(CLOSE-REF(OPEN, Var13))/REF(OPEN, Var13)*100;
Var20:=Var14/CAPITAL*100;
Var21:=MA(CLOSE, 3);
Var22:=REF(CLOSE, 2)*0.865;
Var23:=REF(CLOSE, 13)*0.772;
Var24:=MIN(Var22, Var23);
Var25:=MA(CLOSE, 13);
抄底王:IF((CLOSE-Var24)/CLOSE<0.030 AND Var17<(-35) AND SUM(Var12, 5)/5<1.800, 1, 0)*10, COLORWHITE;
DRAWTEXT(抄底王, 抄底王, ' 成功率 90.22 %,共发出指示1289 次.底 追 '), COLORFFAA00;
Var26:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
Var27:=(EMA(CLOSE, 12)-EMA(CLOSE, 26))*100;
Var28:=EMA(Var27, 9);
Var29:=2*(Var27-Var28);
DRAWTEXT(Var27<(-50) AND Var26>7 AND Var27<Var28, (-10), '底'), COLORWHITE;
DRAWTEXT(Var27<(-50) AND Var26>7 AND Var27>=Var28, 5, '追'), COLORWHITE;
STICKLINE(Var27<(-50) AND Var26>7, 0,(-10), 5, 0), COLORFFFF66;

这个大智慧周期过滤指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。