大智慧公式-FFS+X指标公式

12/16/2018

KG:=FRACPART(CURRENTTIME/3);{时间开关}
if KG<>0 then begin
qq:=KG<>0;
80*qq,COLOR996699;
20*qq,COLORGREEN;
底:10*qq,COLORCC6633,LINETHICK2;
90*qq,COLOR9966FF,LINETHICK2;
50*qq,COLORRED;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长期线:A+100,COLOR9900FF;
短期线:B+100,COLOR888888;
中期线:D+100,COLORYELLOW,LINETHICK2;
见顶:=((REF(中期线,1)>85 ANDREF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线));
顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4,COLORRED;
顶部:=FILTER(顶部区域,4);
STICKLINE( {见顶 OR} 顶部,99,103,20,1 ),COLORRED,LINETHICK2;
底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ,COLORGREEN;
STICKLINE( 底部区域,-4,0,22,0 ),COLORGREEN;
低位金叉:30*(长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 )AND (中期线>=长期线 OR REF( 短期线,1)<1 )),COLORRED;
DRAWGBKLAST(CLOSE>OPEN,STRIP(RGB(0,50,0),RGB(125,50,0),1));
DRAWGBKLAST(CLOSE<OPEN,STRIP(RGB(95,35,0),RGB(0,85,0),1));
end;{==============================================================}
if KG=0 then begin
yy:=KG=0;
{---5日KDJ,27日KDJ--------------------------------金叉共振---}
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
var4:=SMA(RV,3,1);
var5:=SMA(var4,3,1);
KK:=EMA(SMA(RG,3,1),2);
DD:=SMA(KK,3,1);
DRAWTEXTREL(0,10,STKLABEL+' '+STKNAME+''),Color00DDFF;
DRAWTEXT(cross(var4,var5) and cross(KK,DD),10,'共振点'),COLORyellow;
VERTLINE(cross(var4,var5) and cross(KK,DD),1),COLOR00FFFF;
{---MACD------------------------------------------------------}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); {选股设JC=10即可}
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A:=IF(CROSS(0,DEA),1,0);
A1:=IF(DIFF<0 AND CROSS(DIFF,DEA),1,0);
SS:=IF(A,SUM(A1,0),0);
SSB:=HHV(SS,0);
SSS:=SUM(A1,0);
W底选股:IF(SSS-SSB=2 AND SSS>REF(SSS,1),-22,0),LINETHICK2,COLORffff00;
IF(SSS-SSB=2 AND SSS>REF(SSS,1),-12,0),LINETHICK2,COLORffff00;
DRAWTEXT(A1,-8,'W底'),COLORyellow;
VARO5:=LLV(LOW,27);{------------------------------------KDJ---}
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),-6,0) ,COLORyellow,LINETHICK3;
IF((VARO7<10),-3,0) ,COLORblack,LINETHICK3;
MA2:=EMA(C,2);MA5:=EMA(C,5);MA13:=EMA(C,13);MA30:=EMA(C,30);MA55:=EMA(C,55);YCX:=MA5>=REF(MA5,1);H1:=MAX(MAX(MA5,MA13),MA30);L1:=MIN(MIN(MA5,MA13),MA30);一阳穿三线:= H1<C AND O<L1 AND YCX AND MA2>REF(MA2,1);满仓选股:IF(一阳穿三线,38,0),COLORFFFF00,LINETHICK3;
IF(一阳穿三线,30,0),COLORblack,LINETHICK3;
DRAWTEXT(一阳穿三线,42,'满'),COLORffff00;
VAR2:=0.0001*AMOUNT;{------------------------------资金地量---}
MA1:=0.0001*MA(AMOUNT,5);
M2:=0.0001*MA(AMOUNT,10);
百日地量:LLV(VAR2,100)=VAR2,STICK,COLORCC66FF,LINETHICK0;
DRAWTEXT(百日地量,-8,'地'),COLORCC66FF;
AA05:=MA(C,5);{-----------------------------------5日乖离率---}
五日乖离率:=(c-AA05)/AA05*100;
BB05:=atan((aa05/ref(aa05,1)-1)*100)*180/3.1416;
速度5:=sma(ema((AA05-ref(AA05,1))/ref(AA05,1),3)*100,3,1);
加速度5:=ema((速度5-ref(速度5,1)),3);
AA10:=MA(C,10);AA20:=MA(c,20);
BB10:=atan((aa10/ref(aa10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(c-AA30)/AA30*100;{-----------------3日乖离率---}
(AA20-AA30)>ref((AA20-AA30),1) and AA20>ref(aa20,1) and AA30>ref(AA30,1);
(AA30-AA20)<ref((AA30-AA20),1) and AA20<ref(aa20,1) and AA30<ref(AA30,1);
BB30:=atan((aa30/ref(aa30,1)-1)*100)*180/3.1416;
强势狙击选股:filter(BB30>30 and BB10>45 and cross(BB05,60),10);
加仓:=filter(count(cross(BB05,30),5)>=1 and AA05>ref(aa05,1)and 三拾日乖离率>ref(三拾日乖离率,1) and AA10>ref(AA10,1)
and 加速度5>ref(加速度5,1) and 速度5>ref(速度5,1),10) ;
MR:=count(cross(五日乖离率,0),3)>=1 and 三拾日乖离率>ref(三拾日乖离率,1) and AA05>ref(AA05,1) and (c/ref(c,1)-1)*100>5 and ref(c,1)<AA30;
青云直上选股:if(filter(MR,10),30,0),COLORblue,LINETHICK3;
if(filter(MR,10),20,0),COLORblack,LINETHICK3;
DRAWTEXT(青云直上选股,36,'青'),COLORblue;
QUAN:(CLOSE-DMA(CLOSE,VOL/SUM(VOL,13)))/DMA(CLOSE,VOL/SUM(VOL,13))*100<=-28 AND (CLOSE-DMA(CLOSE,VOL/SUM(VOL,34)))/DMA(CLOSE,VOL/SUM(VOL,34))*100<=-19
AND C/REF(C,25)<=1.1 AND IF((((HIGH > (LOW * 1.051)) AND (COUNT((HIGH > (LOW * 1.051)),5) > 1)) AND ((((CLOSE / MA(CLOSE,40)) * 100) < 78) OR
(((CLOSE / MA(CLOSE,60)) * 100) < 74))),2,0) AND
(SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100)<15 AND IF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)>REF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1)
AND REF(SMA((CLOSE-LLV(LOW,8))/
(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),1)<REF(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1),2)
AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)<23 ,1.5,0) AND FILTER((C/MA(C,48))<0.75 AND (C/MA(C,70))<0.70 AND
((C-L)/C>0.02 OR C>REF(C,1)*1.01) AND V<REF(V,1)*2.8 AND (COUNT(C<O*0.93,2)=2 OR COUNT(H/L>1.1,5)>3),3);
DRAWTEXT(QUAN,88,'弱市百发百中'),COLORffff00;
弱市百发百中:IF(QUAN,88,0),COLORffff00,LINETHICK2;
IF(QUAN,60,0),COLORffff00,LINETHICK2;
{---6日RSI--------------------------------------------下破80逃顶---}
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
逃顶:CROSS(80,RSI)*68,LINETHICK3 ,colorgreen;
CROSS(80,RSI)*50,LINETHICK3 ,colorblack;
DRAWTEXT(CROSS(80,RSI),68,'顶 '),colorgreen;
{---乖离率--------------------------------------------------背离---}
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;{-----------KDJ----}
底背离:IF(MN<-4,-11,0),COLORA67D3D,LINETHICK3;
顶背离: IF((VAR26>90),110,100), COLORgreen,LINETHICK3;
IF(MN<-4,-8,0),COLORblack,LINETHICK2;
IF((VAR26>90),106,100), COLORblack,LINETHICK3;
100*yy,COLORffff00, LINETHICK1;
{趋势买卖}{-------------------------------------------------KDJ---}
V1:=LLV(LOW,10);
V2:=HHV(H,25);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
买入:STICKLINE(yy and CROSS(价位线,0.3),50,5,2,0),COLOR00CCFF,LINETHICK1;
STICKLINE(CROSS(价位线,0.3),30,5,2,0),COLORRED,LINETHICK1;
卖出:STICKLINE(yy and CROSS(3.5,价位线),60,100,2,0),COLORRED,LINETHICK1;
STICKLINE(CROSS(3.5,价位线),80,100,2,0),COLORFF9900,LINETHICK1;
DRAWTEXT(CROSS(价位线,0.3),45,'←B'),COLORFFAA66;
DRAWTEXT(CROSS(3.5,价位线),75,'←S'),COLORFFFFCC;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
{---乖离率-------------------------------------------------------}
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离1:=MA(BIAS,3);
乖离:IF(CROSS(BIAS,乖离1) AND 乖离1<-9,28,0),COLORAAAAFF,LINETHICK3;
DRAWTEXT(乖离,32,'乖'),COLORAAAAFF;
IF(CROSS(BIAS,乖离1) AND 乖离1<-9,20,0),COLORblack,LINETHICK3;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
准备建仓:EMA(IF(L<= LLV(L,30),VARC,0),3),COLORff00ff,LINETHICK2;
TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
神偷线:=(((DMP ) * 100) / TR);
辅助线:=((DMM * 100) / TR);
动向趋势线:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),3));
ADXR:=((动向趋势线 + REF(动向趋势线,3)) / 2);
VAR3:=MA(CLOSE,2);
VAR7:=REF(VAR3,1);
【强弱】:=((SMA(MAX((VAR3 - VAR7),0),5,1) / SMA(ABS((VAR3 - VAR7)),5,1)) * 100);
准备:( IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),68,0)),LINETHICK1,COLORFF00FF;
{---CCI-----------------------------------------------------}
TYP := (HIGH + LOW + CLOSE)/3;
cci:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*500-250;
K:=SMA(RSV,3,1);
Var1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(Var1,13)-EMA(Var1,73);
SD:= EMA(SK,2);
买点选股:(cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03)
or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05
and (v/ma(v,5)>2 or c/ref(c,1)>0.035));
IF(买点选股,28,0),COLORyellow,LINETHICK3;
IF(买点选股,22,0),COLORblack,LINETHICK3;
DRAWTEXT(买点选股,32,'买'),COLORyellow;
{---RSI----------------------------------------------------}
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
天之:=(AV + NEWVOL);
低入:if(CROSS(天之,0),28,0),LINETHICK3,COLOR9370DB;
if(CROSS(天之,0),22,0),LINETHICK3,COLORblack;
DRAWTEXT(低入,32,'入'),COLOR9370DB;
N:=20;{----------------------------------------------BOLL-趋势-----}
MID:=MA(C,N);
VART1:=POW((C-MID),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:=REF(MID,1);
UB:=REF(UPPER,1);
LB:=REF(LOWER,1);
LOWER1:=MID-VART3;
LB1:=REF(LOWER1,1);
股价线:(C-LB1)/(UB-LB)*100,COLORyellow, LINETHICK1;
{股价线:((C-LB1)/(UB-LB)-0.3)/0.5*100;}{均衡的-100,+100}
趋势线:MA(股价线,6),COLORred, LINETHICK3;
地量:=VOL<LLV(VOL,30)*1.001;
三十日地量:地量>0,LINETHICK2;
地量1:=VOL<LLV(VOL,60)*1.001;
六十日地量:地量1>0;
地量2:=VOL<LLV(VOL,120)*1.001;
一百二十日地量:地量2>0;
即涨:CROSS(-100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55)),-45)
AND CLOSE>SMA(CLOSE,60,5) AND SMA(CLOSE,23,5)>REF(SMA(CLOSE,23,5),1)
AND SMA(SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,13,1),23,1)>REF(SMA(SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,13,1),23,1),1),COLOrEBC79E,LINETHICK2;
DRAWTEXT(即涨,1.3,'即涨'),COLOREBC79E;

牛大底:"1A0001$CLOSE"/REF("1A0001$CLOSE",23)<0.78
AND C/REF(C,120)<0.558 and ref(c,1)/l<1.5
and ref(c,1)<>ref(o,1) and ref(c,2)<>ref(o,2) and ref(c,3)<>ref(o,3),COLOr4080FF,LINETHICK2;
DRAWTEXT(牛大底,1.8,'牛大底'),COLOR4080FF;
W1:=C=HHV(C,20); {-------------------------突破20日高点---}
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破:W4 AND COUNT(W4,5)=1,LINETHICK2,COLOR4D4DFF;
DRAWTEXT(突破,-5,'突破'),COLORffff00;
90*yy,COLORGREEN, LINETHICK1;
50*yy,COLORwhite, LINETHICK1;
DRAWGBKLAST(CLOSE>OPEN,STRIP(RGB(0,0,55),RGB(95,0,95),1));
DRAWGBKLAST(CLOSE<OPEN,STRIP(RGB(55,0,55),RGB(0,0,95),1));
end;

这个大智慧FFS+X指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。