通达信公式-MACDOBV指标公式

10/24/2019

SHORT:=12;
LONG:=26;
MID:=9;
M:=30;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
OBVH:=CONST(HHV(OBV,FROMOPEN));
OBVL:=CONST(LLV(OBV,FROMOPEN));
DIFH:=CONST(HHV(DIF,FROMOPEN));
DIFL:=CONST(LLV(DIF,FROMOPEN));
X:=(OBVH-OBVL)/(DIFH-DIFL);
XBASE:=(OBVH+OBVL)/2;
XDIF:DIF*X+XBASE,COLORWHITE;
XDEA:EMA(XDIF,MID),COLORYELLOW;
XMACD:=MACD*X;
STICKLINE(XMACD>0,XBASE,XMACD+XBASE,0,1),COLORRED,LINETHICK2;
STICKLINE(XMACDVA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0),COLORGRAY;
MAOBV:MA(OBV,M),DOTLINE,COLORLIRED;
分时前高:HHV(XDIF,0),DOTLINE,COLORCYAN; {箱体上顶}
分时前低:REF(XDIF,LLVBARS(XDIF,0)),DOTLINE,COLORGREEN;{箱体下底};

这个通达信MACDOBV指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。