通达信公式-DMI技术精华指标公式

07/06/2019

N:=14;
M:=5;
TR1 := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:=DMP*100/TR1;
MDI:=DMM*100/TR1;
ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1);
DX:(ADX*14-REF(ADX,1)*13)*IF(PDI>MDI,1,-1);
EMADX:EMA(DX,M);
{60;35;0;-35;-60;100;}
DRAWTEXT(ISLASTBAR,60,'清仓'),COLORRED;
DRAWTEXT(ISLASTBAR,35,'减仓'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,0,'控盘'),COLORWHITE;
DRAWTEXT(ISLASTBAR,-35,'回补'),COLORGREEN;
DRAWTEXT(ISLASTBAR,-60,'吸筹'),COLORBLUE;

这个通达信DMI技术精华指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。