通达信公式-八面威风主图指标公式

11/30/2019

M1:=5;
M2:=10;
M3:=20;
M4:=30;
M5:=60;
V5:=MA(VOL,5);
V10:=MA(VOL,10);
V20:=MA(VOL,20);
LDAY1:=BARSLAST(CROSS(V5,V10));
LDAY2:=BARSLAST(CROSS(V5,V20));
LDAY3:=BARSLAST(CROSS(V10,V20));
LTJ1:=(LDAY1>LDAY2 OR LDAY1=LDAY2) AND LDAY2=0 AND V10<V20;
LTJ2:=(C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2) AND C>REF(C,2));
LTJ:=LTJ1 AND LTJ2;
LTJ0:=LTJ1 AND V10>REF(V10,1);
MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORCYAN;
MA20:MA(C,20),COLORRED;
MA30:MA(C,40),LINETHICK1,DOTLINE,COLORYELLOW;
MA60:MA(C,60),LINETHICK1,DOTLINE,COLORGREEN;
PDAY1:=BARSLAST(CROSS(MA5,MA60));
PDAY2:=BARSLAST(CROSS(MA10,MA60));
PDAY3:=BARSLAST(REF(HIGH=HHV(HIGH,PDAY2),1));
PDAY4:=BARSLAST(CROSS(MA10,MA5));
PDAY5:=BARSLAST(CROSS(MA5,MA10));
A1:=PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;
A2:=COUNT(CROSS(MA10,MA5),PDAY2)=1;
A3:=MA5>MA60 AND MA10>MA60;
LYT:=(A1 AND A2 AND A3) AND FILTER(A1 AND A2 AND A3 ,5),NODRAW;
CSFR:=CROSS(C,MA20) AND CROSS(C,MA30) AND CROSS(C,MA60);
YDAY1:=BARSLAST(CROSS(MA5,MA10));
YDAY2:=BARSLAST(CROSS(MA5,MA20));
YDAY3:=BARSLAST(CROSS(MA10,MA20));
YJZZ:=(YDAY1=YDAY2 AND YDAY2=YDAY3 OR (YDAY1-YDAY2=1 OR YDAY2-YDAY3=1)) AND REF(MA5,2)<REF(MA10,2) AND REF(MA10,2)<REF(MA20,2) AND MA5>MA10 AND MA10>MA20;
YJZZ1:=YDAY1=YDAY2 AND YDAY2=YDAY3 AND MA5>MA10 AND MA10>MA20 AND YDAY1=1;
YJT:=YDAY1>=YDAY2 AND YDAY2=0 AND MA10<MA20;
DAY1:=BARSLAST(CROSS(MA20,MA30));
DAY2:=BARSLAST(CROSS(MA20,MA60));
DAY3:=BARSLAST(CROSS(MA30,MA60));
TJ0:=DAY1>=DAY2 AND DAY3<5;
JZZ:=DAY1=DAY2 AND DAY2=DAY3 AND REF(MA20,1)<REF(MA30,1) AND REF(MA30,1)<REF(MA60,1) AND MA20>MA30 AND MA30>MA60;
TJ1:=DAY1>=DAY2 AND COUNT(CROSS(MA20,MA60),DAY1)=1;
TJ22:=C>O AND CROSS(C,REF(HHV(H,250),1)) AND VOL<V5;
TJ3:=VOL>REF(VOL,1);
TJ4:=MA20>MA60 AND MA30>REF(MA30,1) AND MA30<MA60;
TJ5:=DAY1>=DAY2 AND DAY2=0 AND MA30<MA60;
TJ:=DYNAINFO(4)>0
AND HHV(HIGH,10)/LLV(LOW,10)<1.25
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)
AND CLOSE>OPEN
AND CLOSE>=HHV(HIGH,10);
STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,5,0),COLORYELLOW;
月价托:YJT,NODRAW,COLORYELLOW;
季价托:TJ5,NODRAW,COLORGREEN;
量托:LTJ0,NODRAW,COLORMAGENTA;
老鸭头:LYT,NODRAW,COLORWHITE;
放量突破:TJ,NODRAW,COLORRED;
出水芙蓉:CSFR,NODRAW,COLORCYAN;
多方炮:LTJ,NODRAW,COLORFFAA00;
金蜘蛛:JZZ,NODRAW,COLOR70DB93;
DRAWTEXT(YJT,MA20-0.1,'月价托'),COLORYELLOW;
DRAWTEXT(TJ5,MA60-0.2,'季价托'),COLORGREEN;
DRAWTEXT(LTJ0,H+0.3,'量托'),COLORMAGENTA;
DRAWTEXT(LYT,L+0.1,'老鸭头'),COLORWHITE;
DRAWTEXT(TJ,L-0.3,'放量突破'),COLORRED;
DRAWTEXT(CSFR,H,'出水芙蓉'),COLORGREEN;
DRAWTEXT(TJ22,H+0.2,'轻松过顶'),COLORCYAN;
DRAWTEXT(LTJ,H+0.3,'多方炮'),COLORFFAA00;
DRAWTEXT(JZZ,MA60-0.2,'金蜘蛛'),COLOR70DB93;

这个通达信八面威风主图指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。