通达信公式-立体宝塔指标公式

01/18/2020

B1:=REF(C,1);B2:=REF(C,2);B3:=REF(C,3);B4:=REF(C,4);
CMAX:=MAX(MAX(MAX(C,B1),B2),B3);CMIN:=MIN(MIN(MIN(C,B1),B2),B3);
STICKLINE(C=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND C>=B2 OR
B2=CMAX AND B3=CMIN AND C>=B1 OR B3=CMAX AND C>=B1 AND C>=B2,B1,C,8,0),COLOR000099;
STICKLINE(C=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND C>=B2 OR
B2=CMAX AND B3=CMIN AND C>=B1 OR B3=CMAX AND C>=B1 AND C>=B2,B1,C,5,0),COLOR0000BB;
STICKLINE(C=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND C>=B2 OR
B2=CMAX AND B3=CMIN AND C>=B1 OR B3=CMAX AND C>=B1 AND C>=B2,B1,C,3,0),COLOR0000FF;
STICKLINE(C=CMAX AND B1=CMIN,B2,C,8,0),COLOR000099;
STICKLINE(C=CMAX AND B1=CMIN,B2,C,5,0),COLOR0000BB;
STICKLINE(C=CMAX AND B1=CMIN,B2,C,3,0),COLOR0000FF;
STICKLINE(C=CMIN AND (B1<B2 OR B1<B3) OR B1=CMIN AND (B2=CMAX OR B3=CMAX) AND C<B2 OR
B2=CMIN AND B3=CMAX AND C<B1 OR B3=CMIN AND C<B1 AND C<B2,B1,C,8,0),COLOR009900;
STICKLINE(C=CMIN AND (B1<B2 OR B1<B3) OR B1=CMIN AND (B2=CMAX OR B3=CMAX) AND C<B2 OR
B2=CMIN AND B3=CMAX AND C<B1 OR B3=CMIN AND C<B1 AND C<B2,B1,C,5,0),COLOR00BB00;
STICKLINE(C=CMIN AND (B1<B2 OR B1<B3) OR B1=CMIN AND (B2=CMAX OR B3=CMAX) AND C<B2 OR
B2=CMIN AND B3=CMAX AND C<B1 OR B3=CMIN AND C<B1 AND C<B2,B1,C,3,0),COLOR00FF00;
STICKLINE(B1=CMAX AND C=CMIN,B2,C,8,0),COLOR009900;
STICKLINE(B1=CMAX AND C=CMIN,B2,C,5,0),COLOR00BB00;
STICKLINE(B1=CMAX AND C=CMIN,B2,C,3,0),COLOR00FF00;
STICKLINE(B1=CMIN AND C>=B2 OR (B2=CMIN AND B1<=B3 OR
B3=CMIN AND B1<=B2) AND B2<B4 AND C>=B1,B1,B2,8,0),COLORFF9900;
STICKLINE(B1=CMIN AND C>=B2 OR (B2=CMIN AND B1<=B3 OR
B3=CMIN AND B1<=B2) AND B2<B4 AND C>=B1,B1,B2,5,0),COLORFFBB00;
STICKLINE(B1=CMIN AND C>=B2 OR (B2=CMIN AND B1<=B3 OR
B3=CMIN AND B1<=B2) AND B2<B4 AND C>=B1,B1,B2,3,0),COLORFFFF00;
STICKLINE(B1=CMAX AND C<B2 OR (B2=CMAX AND B1>B3 OR
B3=CMAX AND B1>B2) AND B2>=B4 AND C<B1,B1,B2,8,0),COLOR000099;
STICKLINE(B1=CMAX AND C<B2 OR (B2=CMAX AND B1>B3 OR
B3=CMAX AND B1>B2) AND B2>=B4 AND C<B1,B1,B2,5,0),COLOR0000BB;
STICKLINE(B1=CMAX AND C<B2 OR (B2=CMAX AND B1>B3 OR
B3=CMAX AND B1>B2) AND B2>=B4 AND C<B1,B1,B2,3,0),COLOR0000FF;

这个通达信立体宝塔指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。