通达信公式-神奇的探温针主图指标公式

01/14/2020

N:=120;
K:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:=IF(CURRBARSCOUNT平衡:=IF(CURRBARSCOUNT压力:=IF(CURRBARSCOUNT支撑:=IF(CURRBARSCOUNT高:=IF(CURRBARSCOUNT低:=IF(CURRBARSCOUNTDRAWBAND(高,RGB(160,160,0),压力,RGB(0,0,0));
DRAWBAND(压力,RGB(130,0,0),平衡,RGB(0,0,0));
DRAWBAND(平衡,RGB(100,0,100),支撑,RGB(0,0,0));
DRAWBAND(支撑,RGB(150,150,150),低,RGB(0,0,0));
止损:=REF(HHV(H,5),3)*0.925,COLORGRAY,DOTLINE;
STICKLINE(CURRBARSCOUNT=1,止损,止损,80,-1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=N/30,GD,DD,0,0),COLORGREEN;{划左侧高低点边线}
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;{划右侧高低点边线}
STICKLINE(CURRBARSCOUNTSTICKLINE(CURRBARSCOUNTSTICKLINE(CURRBARSCOUNTSTICKLINE(CURRBARSCOUNTVAR93:=CLOSE=LLV(C,4) AND (REF(C,1)VAR94:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=REF(C,1);
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(VAR93,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;
STICKLINE(VAR93,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;
STICKLINE(VAR94,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(VAR94,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
DRAWTEXT_FIX(ISLASTBAR,0.80,0,1,'止损价:'),COLORGREEN;
DRAWNUMBER_FIX(ISLASTBAR,0.805,0,0,REF(HHV(H,5),3)*0.925)COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.80,0.1,1,'买进价:'),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.805,0.1,0,REF(C,1)*1.043)COLORRED;
CCI151:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,15))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,15));
CCI101:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,10))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,10));
CCI51:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,5))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,5));
CCI31:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,3))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,3));
CCI买点定位1:=CROSS(CCI51,0) AND CROSS(CCI31,0) AND REF(CCI151,1)>0 AND REF(CCI101,1)>-30 AND REF(CCI151,1)>REF(CCI101,1) AND REF(CCI101,1)>REF(CCI51,1);
CCI买点定位2:=CROSS(CCI31,0) AND CCI51>REF(CCI51,1) AND REF(CCI51,1)0 AND REF(CCI101,1)>-30 AND REF(CCI151,1)>REF(CCI101,1) AND REF(CCI101,1)>REF(CCI51,1);
CCI买点定位3:=CROSS(CCI51,0) AND CROSS(CCI31,0) AND REF(CCI101,1)>0 AND REF(CCI101,1)>REF(CCI151,1);
买点定位:=CCI买点定位1=1 OR CCI买点定位2=1 OR CCI买点定位3=1;
VOL比:=VOL/REF(VOL,1);
出现买点:=买点定位 AND VOL比>1.2;
STICKLINE(出现买点,O,C,3,0),COLOR2CB3E3;
DRAWTEXT(出现买点 ,L*0.98,'出现买点')COLORYELLOW;
DRAWICON(出现买点,L*0.99,1);

这个通达信神奇的探温针主图指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。