通达信公式-双龙之翼主图指标公式

12/19/2019

上轨:EMA(H,25),COLORGREEN,LINETHICK2;
下轨:EMA(L,25),COLORGREEN,LINETHICK2;
NA1:=PLOYLINE(C>上轨,上轨);
IF(C>上轨,NA1,DRAWNULL),COLORRED,LINETHICK2;
NB1:=PLOYLINE(C>下轨,下轨);
IF(C>下轨,NB1,DRAWNULL),COLORRED,LINETHICK2;
{变色K线}
QS:=(C+上轨+下轨)/3;
STICKLINE(C>REF(QS,1) AND O>=C,C,O,-1,0),COLORRED;
STICKLINE(C>REF(QS,1) AND O>=C,L,H,0,0),COLORRED;
STICKLINE(CSTICKLINE(CSTICKLINE(C==REF(QS,1) AND O{涨停K线}
ZT_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
ZT_2:=ZT_1>=0.099 AND CLOSE=HIGH AND LOW!=HIGH;
STICKLINE(ZT_2,OPEN,CLOSE,2,0),COLORYELLOW;
{KDJ测顶底}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
{文字或图标任换一种:}
{DRAWTEXT(CROSS(100,J),H*1.02,'顶'),COLORGREEN;
DRAWTEXT(CROSS(J,0),L*0.97,'底'),COLORRED;}
{2.∧∨图标}
{DRAWICON(CROSS(J,0),L*0.98,34);
DRAWICON(CROSS(100,J),H*1.02,35);}
{3.笑哭图标}
DRAWICON(CROSS(J,0),L*0.98,5);
DRAWICON(CROSS(100,J),H*1.02,6);
{九转}
A1:=C>REF(C,4);
A2:=CT1:=A2 AND REF(A1,1);
T2:=A2 AND REF(T1,1);
T3:=A2 AND REF(T2,1);
T4:=A2 AND REF(T3,1);
T5:=A2 AND REF(T4,1);
T6:=A2 AND REF(T5,1);
T7:=A2 AND REF(T6,1);
T8:=A2 AND REF(T7,1);
T9:=A2 AND REF(T8,1);
DRAWTEXT(T6,L*0.99,'6'),COLORGREEN;
DRAWTEXT(T7,L*0.99,'7'),COLORGREEN;
DRAWTEXT(T8,L*0.99,'8'),COLORGREEN;
DRAWTEXT(T9,L*0.99,'9'),COLORGREEN;
B1:=CB2:=C>REF(C,4);
D1:=B2 AND REF(B1,1);
D2:=B2 AND REF(D1,1);
D3:=B2 AND REF(D2,1);
D4:=B2 AND REF(D3,1);
D5:=B2 AND REF(D4,1);
D6:=B2 AND REF(D5,1);
D7:=B2 AND REF(D6,1);
D8:=B2 AND REF(D7,1);
D9:=B2 AND REF(D8,1);
DRAWTEXT(D6,H*1.01,'6'),COLORYELLOW;
DRAWTEXT(D7,H*1.01,'7'),COLORYELLOW;
DRAWTEXT(D8,H*1.01,'8'),COLORYELLOW;
DRAWTEXT(D9,H*1.01,'9'),COLORYELLOW;

这个通达信双龙之翼主图指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。