大智慧公式-未来分析主图指标公式

11/29/2018

input:n(4),n1(25);
Var0:=EMA(EMA(EMA(CLOSE,N),N),N);
VAR1: Var0-REF(Var0,1)+Var0,linethick2;
VAR2: MA(VAR1,n1);
STICKLINE(VAR1>VAR2,VAR2,VAR1,0.1,1),colorred;
STICKLINE(VAR2>VAR1,VAR1,VAR2,0.1,1),colorf0f000;
DRAWTEXT(CROSS(VAR2,VAR1),VAR1*1.01,'▼'),Color00FF00,ALIGN1;
DRAWTEXT(CROSS(VAR1,VAR2),VAR2*0.99,'▲'),COLORYELLOW,ALIGN1;
{解盘}
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
TJTS1:=BARSTATUS=2 and c<200;
TJTS2:=BARSTATUS=2 and c>200;
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
k2:=hhv(h*1.03,barslast(DISPSTATUS=1)+1);
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,轻仓者可以观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股放量下跌,走势明显偏弱,离场观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股缩量下跌,走势偏弱,离场观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态良好,强势明显,量能充足,可以继续持有。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股上行趋势不变,强势依然,但量能开始转弱,注意风险。'),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股走势趋弱,量能不足,减持大部分筹码。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态不佳,注意成交量的变化,但目前不适合参与。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股走势太弱,没有参与价值。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.99,'★大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.98,'★如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),ALIGN2,color0000FF,LINETHICK2;

DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.99,'★大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.98,' ★可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 >= V2)) ,k2*0.99,'★大盘形态走坏,重仓者可以减去大部分仓位。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 < V2)) ,k2*0.99,'★大盘缩量调整,注意风险,短线清仓观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) ,k2*0.99,'★大盘走势良好,量能理想,可以继续持有强势股。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) ,k2*0.99,'★大盘形态良好,但量能稍显不足,随时准备减仓。 '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) ,k2*0.99,'★大盘趋势不明,注意成交量变化,目前不适宜进场。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) ,k2*0.99,'★大盘趋势向下,量能萎缩,不适合进场。 '),ALIGN2,LINETHICK2;

这个大智慧未来分析主图指标公式是由公式指标网收集提供,更多的大智慧公式请你访问:http://gupiao.geren-jianli.org/category/dzh/查看。