通达信公式-汽枪猎杀及选股指标公式

08/06/2019

汽枪:=SMA(SMA((C-LLV(L,80))/(HHV(H,80)-LLV(L,80))*100,10,1),10,1),LINETHICK2;
收兵:=SMA(汽枪,10,1),LINETHICK2,COLOR808000;
W1:=SMA((HHV(H,80)-C)/(HHV(H,80)-LLV(L,80))*100,10,1);
瞄准:SMA(W1,10,1),CIRCLEDOT,COLOR00DD00,LINETHICK1;
天空:STICKLINE(C,85,85,5,1);
大地:STICKLINE(C,9,9,5,1);
W2:=(CROSS(收兵,汽枪) AND 收兵>20);
W3:=(CROSS(汽枪,收兵) AND 收兵DRAWTEXT(CROSS(收兵,汽枪) AND 收兵>20,58,'杀'),COLORFF00FF;
DRAWTEXT(CROSS(收兵,汽枪) AND 收兵20,汽枪,' 留意!'),COLORFF00FF;
IF(W2,60,85),COLOR00DD00;
IF(W3,40,9),COLORFF00FF;
DRAWTEXT(CROSS(汽枪,收兵) AND 收兵DRAWTEXT(CROSS(瞄准,80),82,'●'),COLORRED;
DRAWTEXT(CROSS(瞄准,80),76,'瞄准'),COLORRED;
DRAWTEXT(CROSS(瞄准,85),84,'●'),COLORWHITE;
DRAWTEXT(CROSS(瞄准,85),78,'猎物出现'),COLORWHITE;
VAR1:=4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
VAR2:=8;
底部出击: IF(CROSS(VAR1,VAR2),50,9),COLORRED;
A1:=CROSS(汽枪,85) AND 汽枪>=85;
再来一枪:IF(A1,60,85),COLORYELLOW;
猎杀:瞄准=90;
DRAWTEXT(猎杀=1,95,'★'),COLORYELLOW;
DRAWTEXT(猎杀=1,93,'猎杀'),COLORRED;
成功:瞄准REF(瞄准,1) AND CROSS(85,瞄准);
DRAWTEXT(成功=1,85,'◆●'),COLORYELLOW;
DRAWTEXT(成功=1,83,'成功'),COLOR17CCC8;
VA1:=MA(L,1);
VA2:=MA(H,2);
VAR3:=MA(C,2);
VAR4:=(VAR3-LLV(VA1,9))/(HHV(VA2,9)-LLV(VA1,9))*100;
VAR5:=SMA(VAR4,3,1);
【阳】:SMA(VAR5,3,1),LINETHICK2,COLOR0000FF;
K2:=BACKSET(【阳】IF(K2,【阳】,DRAWNULL),COLOR00A600,LINETHICK2;
IF(【阳】>REF(【阳】,1),【阳】,DRAWNULL),COLOR740AF5,LINETHICK8,POINTDOT;
Y1:=SMA(【阳】,3,1);
VAR6:=(HHV(VA2,9)-VAR3)/(HHV(VA2,9)-LLV(VA1,9))*100;
【阴】:SMA(VAR6,3,1),LINETHICK2,COLORWHITE;
Y2:=SMA(【阴】,3,1);
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;
VARC:=MA(C,3)*100/MA(C,10)-100;
VARD:=C*100/MA(C,10)-100;
VARE:=IF(VARB>10,10,VARB);
VARF:=IF(VAREVAR10:=IF(VARC>10,10,VARC);
VAR11:=IF(VAR10VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR14:=INDEXC;
VAR15:=REF(VAR14,1);
VAR16:=100*(VAR14-VAR15)/VAR14;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*C+VAR1+O+H)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1C:=EMA(VAR1A,5);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(INDEXC,1);
D1:=EMA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,2.5,0),COLOR00AAFF;
STICKLINE(D1>=REF(D1,1),D1,D2,1.5,0),COLOR99AAFF;
STICKLINE(D1>=REF(D1,1),D1,D2,1,0),COLOR99DDFF;
【强弱】:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100,LINETHICK2,COLORYELLOW;
DRAWTEXT(ISLASTBAR=1 AND CROSS(【强弱】,【阳】),【阳】,'短期吃货!'),COLORFFFFCC;
DRAWTEXT( CROSS(【强弱】,【阳】),【强弱】,'←◆'),COLORRED;
DRAWTEXT( CROSS(【强弱】,【阳】),【强弱】,'←吃货'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND CROSS(【阳】,【强弱】),【阳】,'短期出货!'),COLOR00FF00;
DRAWTEXT( CROSS(【强弱】,【阴】),【强弱】,'●▼'),COLORCYAN;
DRAWTEXT( CROSS(【强弱】,【阴】),【强弱】,'←出货!'),COLORCYAN;
DRAWTEXT(ISLASTBAR=1 AND VAR17>VAR18,60,'个股强于大盘!'),COLORFF66FF;
DRAWTEXT(ISLASTBAR=1 AND VAR12>VARF,50,'大盘处在下降通道'),COLORCCFF99;
DRAWTEXT(ISLASTBAR=1 AND VAR18>=VAR17,60,'个股弱于大盘!'),COLORFFFF00;
DRAWTEXT(ISLASTBAR=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,' 持股待涨!'),COLOR6699FF;
DRAWTEXT(ISLASTBAR=1 AND VAR1ADRAWTEXT(ISLASTBAR=1 AND VAR1DDRAWTEXT(ISLASTBAR=1 AND (INDEXC-VAR1F)/VAR1F>0.035,40,'出现井喷行情!');

{
选股公式:

猎枪:=SMA(SMA((C-LLV(L,80))/(HHV(H,80)-LLV(L,80))*100,10,1),10,1);
收兵:=SMA(猎枪,10,1);
W1:=SMA((HHV(H,80)-C)/(HHV(H,80)-LLV(L,80))*100,10,1);
瞄准:=SMA(W1,10,1);
W3:=(CROSS(猎枪,收兵) AND 收兵VAR1:=4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
VAR2:=8;
底部出击:=CROSS(VAR1,VAR2);
开枪:=瞄准=90;
成功:=瞄准REF(瞄准,1) AND CROSS(85,瞄准);
D1:=EMA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);
VA1:=MA(L,1);
VA2:=MA(H,2);
VAR3:=MA(C,2);
VAR4:=(VAR3-LLV(VA1,9))/(HHV(VA2,9)-LLV(VA1,9))*100;
VAR5:=SMA(VAR4,3,1);
【阳】:=SMA(VAR5,3,1);
VAR7:=REF(VAR3,1);
【强弱】:=SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100;
XG:REF(底部出击=1,6) OR D1>=REF(D1,1) AND CROSS(【强弱】,【阳】);
}

这个通达信汽枪猎杀及选股指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。