通达信公式-自用黄金分割划线玩具主图指标公式

11/18/2018

N:=144;M:=2;HH:=1.10;LL:=0.1;NUL:=1;BL1:=0.382;BL2:=0.5;BL3:=0.618;
MA5:MA(C,5),COLORWHITE;
MA13:MA(C,13),COLORYELLOW;
MA55:MA(C,55),COLORGREEN;
MA144:MA(C,144),COLORBLUE;
高1:=REF(HHV(H,N),M);
低1:=REF(LLV(L,N),M);
高:=IF(HH=1.1,高1,HH);
低:=IF(LL=0.1,低1,LL);
ZF:(高-低)/高*100,NODRAW;
H1:=高-(高-低)*BL1;
H2:=高-(高-低)*BL2;
H3:=高-(高-低)*BL3;
高点:IF(NUL=1,REFDATE(高,DATE),DRAWNULL),DOTLINE,COLORWHITE;
W1:IF(NUL=1,REFDATE(H1,DATE),DRAWNULL),DOTLINE,COLORMAGENTA;
W2:IF(NUL=1,REFDATE(H2,DATE),DRAWNULL),DOTLINE,COLORRED;
W3:IF(NUL=1,REFDATE(H3,DATE),DRAWNULL),DOTLINE,COLORMAGENTA;
低点:IF(NUL=1,REFDATE(低,DATE),DRAWNULL),DOTLINE,COLORWHITE;
DRAWTEXT(ISLASTBAR && NUL=1,高点,'高点'),COLORWHITE;
DRAWTEXT(ISLASTBAR && NUL=1,W1,CON2STR(BL1,3)),COLORMAGENTA;
DRAWTEXT(ISLASTBAR && NUL=1,W2,CON2STR(BL2,3)),COLORRED;
DRAWTEXT(ISLASTBAR && NUL=1,W3,CON2STR(BL3,3)),COLORMAGENTA;
DRAWTEXT(ISLASTBAR && NUL=1,低点,'低点'),COLORWHITE;
ZT:=C>REF(C,1)*1.098 AND C<REF(C,1)*1.102;
DT:=C<REF(C,1)*0.902 AND C>REF(C,1)*0.898;
STICKLINE(ZT,C,O,2.8,0),COLORRED;
STICKLINE(DT,C,O,2.8,0),COLORBLUE;

这个通达信自用黄金分割划线玩具主图指标公式是由公式指标网收集提供,更多的通达信公式请你访问:http://gupiao.geren-jianli.org/category/tdx/查看。